选股公式 股市行情 抄底公式
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 股票行情 今日大盘 上证指数 指标 macd boll kdj obv cci rsi dmi sar vol ddx ddy wr ddz
股票软件 指数 创业板指数 科创板 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 外汇 期货 基金 操盘手 财经股票 股票入门 炒股技巧
/
当前位置:首页 >> 指标公式 >>  大智慧指标公式
数浪主图指标公式改为大智慧主图公式
  • 相关简介: 今日股市
  • 内容标签: 数浪主图,指标公式,大智慧主图公式
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2020-04-07 17:49:01
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

编写要求:

数浪主图指标公式改为大智慧主图公式

{K线} STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred; STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred; STICKLINE(CLOSE<open or="" close="OPEN" and="" close<="REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;" stickline(close=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00; STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF; STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF; pl5:=zig(3,5); en1:=zig(3,5)>ref(zig(3,5),1) and ref(zig(3,5),1)<=ref(zig(3,5),2) and ref(zig(3,5),2)<=ref(zig(3,5),3); ex1:=zig(3,5)=ref(zig(3,5),2) and ref(zig(3,5),2)>=ref(zig(3,5),3); pl10:=zig(3,13); en2:=zig(3,10)>ref(zig(3,10),1) and ref(zig(3,10),1)<=ref(zig(3,10),2) and ref(zig(3,10),2)<=ref(zig(3,10),3); ex2:=zig(3,10)=ref(zig(3,10),2) and ref(zig(3,10),2)>=ref(zig(3,10),3); pl20:=zig(3,26); en3:=zig(3,20)>ref(zig(3,20),1) and ref(zig(3,20),1)<=ref(zig(3,20),2) and ref(zig(3,20),2)<=ref(zig(3,20),3); ex3:=zig(3,20)=ref(zig(3,20),2) and ref(zig(3,20),2)>=ref(zig(3,20),3); pl40:=zig(3,55); { pl5:=HHV(H,5); pl10:=HHV(H,13); pl20:=HHV(H,26); pl40:=HHV(H,55); en1:=pl5>ref(pl5,1) and ref(pl5,1)<=ref(pl5,2) and ref(pl5,2)<=ref(pl5,3); ex1:=pl5=ref(pl5,2) and ref(pl5,2)>=ref(pl5,3); en2:=pl10>ref(pl10,1) and ref(pl10,1)<=ref(pl10,2) and ref(pl10,2)<=ref(pl10,3); ex2:=pl10=ref(pl10,2) and ref(pl10,2)>=ref(pl10,3); en3:=pl20>ref(pl20,1) and ref(pl20,1)<=ref(pl20,2) and ref(pl20,2)<=ref(pl20,3); ex3:=pl20=ref(pl20,2) and ref(pl20,2)>=ref(pl20,3); } 走强1:=barslast(pl5ref(pl5,1)); 走强2:=barslast(pl10ref(pl10,1)); 走强3:=barslast(pl20ref(pl20,1)); ztjz5:=if(pl10>ref(pl10,1),count(en1,走强2),0); ztjd5:=if(pl10>ref(pl10,1),count(ex1,走强2),0); dtjz5:=if(pl10ref(pl20,1),count(en2,走强3),0); ztjd10:=if(pl20>ref(pl20,1),count(ex2,走强3),0); dtjz10:=if(pl20ref(pl10,1) and ztjd5=1,h*1.02,'⑴'),colorff; drawtext(en1 and pl10>ref(pl10,1) and ztjz5=2,l*0.98,'⑵'),colorff; drawtext(ex1 and pl10>ref(pl10,1) and ztjz5=2,h*1.02,'⑶'),colorff; drawtext(en1 and pl10>ref(pl10,1) and ztjz5=3,l*0.98,'⑷'),colorff; drawtext(ex2 and pl20>ref(pl20,1) and ztjd10=1,h*1.02,'⑸'),colorff; drawtext(en2 and dtjz10=1,l*0.94,'【A】'),color00ff00; drawtext(ex2 and dtjd10=2,h*1.03,'【B】'),color00ff00; drawtext(en3 and ztjz10=1,l*0.94,'【C】'),color00ff00; drawtext(ex2 and pl20>ref(pl20,1) and ztjd10=1,h*1.04,'①'),Linethick3,colorffff; drawtext(en2 and pl20>ref(pl20,1) and ztjz10=2,l*0.94,'②'),Linethick3,colorffff; drawtext(ex2 and pl20>ref(pl20,1) and ztjd10=2 or (ztjd10=0 or ztjd10=2) and ex2,h*1.04,'③'),Linethick3,colorffff; drawtext(en2 and pl20>ref(pl20,1) and ztjz10=3,l*0.94,'④'),Linethick3,colorffff; DMLJ:=HHV(H,120); DMLK:=HHV(H,10); LM:=LLV(L,120); LG:=LLV(L,10); PL100:=IF(C>1000,LM,LG); DL100:=IF(C>1000,DMLJ,DMLK); qj1:=pl100*1.382;qj2:=pl100*1.500;qj3:=pl100*1.618;qj4:=pl100*1.809;xh5:=pl100*1.3820*1.3820; dj1:=Dl100/1.382;dj2:=Dl100/1.500;dj3:=Dl100/1.618;dj4:=Dl100/1.809;dj5:=Dl100/1.3820/1.3820; {dj1:=Dl100/1.382;dj2:=Dl100/1.500;dj3:=Dl100/1.618;dj4:=Dl100/1.809;} DRAWTEXT(BARPOS=SYSPARAM(2),H,'\N所属板块:'+BLKNAME),ALIGN4,COLORYELLOW; 地心引力线:(MA(C,30)+MA(C,72))/2,LINETHICK1; D2大盘用高10%:地心引力线*1.1,COLORWHITE,LINETHICK1; D3大盘用低7%:地心引力线*0.93,COLORWHITE,LINETHICK1; MA10:MA(C,10),COLORRED,LINETHICK2; MA20:MA(C,20),COLORYELLOW,LINETHICK2; MA144:MA(C,144),LINETHICK1;

操盘手公式网官方签约公式老师专业解答源码如下


{K线}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
pl5:=zig(3,5);
en1:=zig(3,5)>ref(zig(3,5),1) and ref(zig(3,5),1)<=ref(zig(3,5),2) and ref(zig(3,5),2)<=ref(zig(3,5),3);
ex1:=zig(3,5)<ref(zig(3,5),1) and ref(zig(3,5),1)>=ref(zig(3,5),2) and ref(zig(3,5),2)>=ref(zig(3,5),3);
pl10:=zig(3,13);
en2:=zig(3,10)>ref(zig(3,10),1) and ref(zig(3,10),1)<=ref(zig(3,10),2) and ref(zig(3,10),2)<=ref(zig(3,10),3);
ex2:=zig(3,10)<ref(zig(3,10),1) and ref(zig(3,10),1)>=ref(zig(3,10),2) and ref(zig(3,10),2)>=ref(zig(3,10),3);
pl20:=zig(3,26);
en3:=zig(3,20)>ref(zig(3,20),1) and ref(zig(3,20),1)<=ref(zig(3,20),2) and ref(zig(3,20),2)<=ref(zig(3,20),3);
ex3:=zig(3,20)<ref(zig(3,20),1) and ref(zig(3,20),1)>=ref(zig(3,20),2) and ref(zig(3,20),2)>=ref(zig(3,20),3);
pl40:=zig(3,55);
{
pl5:=HHV(H,5);
pl10:=HHV(H,13);
pl20:=HHV(H,26);
pl40:=HHV(H,55);
en1:=pl5>ref(pl5,1) and ref(pl5,1)<=ref(pl5,2) and ref(pl5,2)<=ref(pl5,3);
ex1:=pl5<ref(pl5,1) and ref(pl5,1)>=ref(pl5,2) and ref(pl5,2)>=ref(pl5,3);
en2:=pl10>ref(pl10,1) and ref(pl10,1)<=ref(pl10,2) and ref(pl10,2)<=ref(pl10,3);
ex2:=pl10<ref(pl10,1) and ref(pl10,1)>=ref(pl10,2) and ref(pl10,2)>=ref(pl10,3);
en3:=pl20>ref(pl20,1) and ref(pl20,1)<=ref(pl20,2) and ref(pl20,2)<=ref(pl20,3);
ex3:=pl20<ref(pl20,1) and ref(pl20,1)>=ref(pl20,2) and ref(pl20,2)>=ref(pl20,3);
}
走强1:=barslast(pl5<ref(pl5,1));
走弱1:=barslast(pl5>ref(pl5,1));
走强2:=barslast(pl10<ref(pl10,1));
走弱2:=barslast(pl10>ref(pl10,1));
走强3:=barslast(pl20<ref(pl20,1));
走弱3:=barslast(pl20>ref(pl20,1));
ztjz5:=if(pl10>ref(pl10,1),count(en1,走强2),0);
ztjd5:=if(pl10>ref(pl10,1),count(ex1,走强2),0);
dtjz5:=if(pl10<ref(pl10,1),count(en1,走弱2),0);
dtjd5:=if(pl10<ref(pl10,1),count(ex1,走弱2),0);
ztjz10:=if(pl20>ref(pl20,1),count(en2,走强3),0);
ztjd10:=if(pl20>ref(pl20,1),count(ex2,走强3),0);
dtjz10:=if(pl20<ref(pl20,1),count(en2,走弱3),0);
dtjd10:=if(pl20<ref(pl20,1),count(ex2,走弱3),0);
drawtext(en1 and dtjz5=1,l*0.98,'(Ⅰ)'),colorffff00;
drawtext(ex1 and dtjd5=2,h*1.02,'(Ⅱ)'),colorffff00;
drawtext(en2 and ztjz5=1,l*0.98,'(Ⅲ)'),colorffff00;
drawtext(ex1 and pl10>ref(pl10,1) and ztjd5=1,h*1.02,'⑴'),color0000ff;
drawtext(en1 and pl10>ref(pl10,1) and ztjz5=2,l*0.98,'⑵'),color0000ff;
drawtext(ex1 and pl10>ref(pl10,1) and ztjz5=2,h*1.02,'⑶'),color0000ff;
drawtext(en1 and pl10>ref(pl10,1) and ztjz5=3,l*0.98,'⑷'),color0000ff;
drawtext(ex2 and pl20>ref(pl20,1) and ztjd10=1,h*1.02,'⑸'),color0000ff;
drawtext(en2 and dtjz10=1,l*0.94,'【A】'),color00ff00;
drawtext(ex2 and dtjd10=2,h*1.03,'【B】'),color00ff00;
drawtext(en3 and ztjz10=1,l*0.94,'【C】'),color00ff00;
drawtext(ex2 and pl20>ref(pl20,1) and ztjd10=1,h*1.04,'①'),Linethick3,colorffff00;
drawtext(en2 and pl20>ref(pl20,1) and ztjz10=2,l*0.94,'②'),Linethick3,colorffff00;
drawtext(ex2 and pl20>ref(pl20,1) and ztjd10=2 or (ztjd10=0 or ztjd10=2) and ex2,h*1.04,'③'),Linethick3,colorffff00;
drawtext(en2 and pl20>ref(pl20,1) and ztjz10=3,l*0.94,'④'),Linethick3,colorffff00;
DMLJ:=HHV(H,120);
DMLK:=HHV(H,10);
LM:=LLV(L,120);
LG:=LLV(L,10);
PL100:=IF(C>1000,LM,LG);
DL100:=IF(C>1000,DMLJ,DMLK);
qj1:=pl100*1.382;qj2:=pl100*1.500;qj3:=pl100*1.618;qj4:=pl100*1.809;xh5:=pl100*1.3820*1.3820;
dj1:=Dl100/1.382;dj2:=Dl100/1.500;dj3:=Dl100/1.618;dj4:=Dl100/1.809;dj5:=Dl100/1.3820/1.3820;
{dj1:=Dl100/1.382;dj2:=Dl100/1.500;dj3:=Dl100/1.618;dj4:=Dl100/1.809;}
地心引力线:(MA(C,30)+MA(C,72))/2,LINETHICK1;
D2大盘用高10:地心引力线*1.1,COLORWHITE,LINETHICK1;
D3大盘用低7:地心引力线*0.93,COLORWHITE,LINETHICK1;
MA10:MA(C,10),COLORRED,LINETHICK2;
MA20:MA(C,20),COLORYELLOW,LINETHICK2;
MA144:MA(C,144),LINETHICK1;


版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供指标公式,选股公式,股票公式,股票软件,股票入门基础知识,财经股票,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
关闭
“炒股公式”width="120"
关闭
“抄底公式”
关闭
关闭
关闭
关闭