当前位置:首页 >> 指标公式 >>  通达信指标公式
通达信MACD优化波段指标公式
  • 相关简介: 今日股市
  • 内容标签: 通达信,MACD优化,波段指标公式
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2019-06-20 09:06:39
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

通达信MACD优化波段指标公式

A:=CURRBARSCOUNT;
A1:=DAY!=REF(DAY,1);
A2:=BARSLAST(A1)+1;
A3:=MA(C,A2);
A4:=SUM(AMO,A2)/SUM(VOL,A2)/100;
A5:=IF(CAPITAL>0,A4,A3);
均价线:=IF(A<=CONST(A2),A5,DRAWNULL);
分钟有效周期:=IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,DRAWNULL))));
分时价:=TFILT(CLOSE,CURRBARSCOUNT,00,CURRBARSCOUNT,00);
分时判断:=IF(分时价=DRAWNULL,1,IF(分钟有效周期=DRAWNULL,DRAWNULL,1));
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
KX:=BARSSINCE(CLOSE);{←首次开盘价距金的天数}
HHN:=CONST(HHV(DIFF,KX));
HLN:=CONST(LLV(DEA,KX));
RC1:=CONST((HHN+HLN)/2);
SS:=((HHN-HLN)/200);
MACD底部:=(-100*SS+RC1)+-(-100*SS+RC1),COLOR669999;
MACD顶部:=(100*SS+RC1)+-(-100*SS+RC1),COLORFF0033;
MACD中轴:=0+-(-100*SS+RC1);
DIFF修正:=DIFF+-(-100*SS+RC1),COLOR008080;
DEA修正:=DEA+-(-100*SS+RC1),COLOR00FF00;
MACD修正:=2*(DIFF修正-DEA修正)+MACD中轴,COLOR0000BB,NODRAW;
MACD超跌:=CONST(LLV(MACD修正,KX));
MACD超跌线:=IF(MACD超跌<MACD底部,MACD超跌,MACD底部);
{----------------------利用MACD趋势进行精确顶底判断------------------------}
顶部:=MACD顶部+-MACD超跌线;
天际:=顶部*0.809;
中轴:=MACD中轴+-MACD超跌线;
海面:=顶部*0.191;
底部:=MACD底部;
{------------------------传统KDJ指标结合MACD优化---------------------------}
RSVA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*顶部;{采用21日月线优化}
K:SMA(RSVA,3,1),COLORFFFFFF,NODRAW;
D:SMA(K,3,1),COLOR00FFFF,NODRAW;
原J值参数:=3*K-2*D;
JD:=IF(原J值参数<底部,底部,原J值参数);{J值底部钝化处理}
J:IF(JD>顶部,顶部,JD),COLORFF00FF,NODRAW;{底部钝化处理后再进行顶部钝化处理}
{---------------------------MACD多空量能判断-------------------------------}
MACD多头:=DIFF修正+-MACD超跌线,COLOR339999;
空头:=DEA修正+-MACD超跌线,COLOR00FF00;
量能柱:2*(MACD多头-空头)+中轴,COLOR0000BB,NODRAW;
超前DEA:=(EMA(MACD多头,7));
超前MACD:=2*(MACD多头-超前DEA)+中轴;
{-----------------------------------大盘动向-------------------------------}
VAR1大盘:=LLV(LOW,13);
VAR2大盘:=HHV(HIGH,13);
VAR3大盘:=(SMA((CLOSE-VAR1大盘)/(VAR2大盘-VAR1大盘)*顶部,5,1))-顶部/2;
VAR4大盘:=SMA((VAR2大盘-CLOSE)/(VAR2大盘-VAR1大盘)*顶部,5,1)-顶部/2;
大盘散户:=IF(VAR4大盘<底部,底部,VAR4大盘),COLOR408000;
大盘主力:=IF(VAR3大盘<底部,底部,VAR3大盘),COLOR330088;
{---------------------------------密集成本突破-----------------------------}
最高获利参数:=顶部/100;
VAR1C:=(COST(89)-COST(11))*最高获利参数;
VAR2C:=(COST(99.9)-COST(1))*最高获利参数;
单峰:=((1-VAR1C/VAR2C))*顶部;
低密:=((COST(90)-COST(60))/VAR2C)*顶部;
高密:=((COST(40)-COST(1))/VAR2C)*顶部;
赢利:= (SMA(WINNER(AMOUNT/VOL/99),2,1))*顶部;
活跃度:顶部-顶部/(1+EXPMA(HSL,21)),COLOR774455;{←CYF公众追涨热情指标}
70%成本集中度:=IF(VAR1C>顶部,顶部,VAR1C),COLORFFFFFF;
90%成本集中度:=IF(VAR2C>顶部,顶部,VAR2C),COLORFF0000;
套牢筹码上升:=IF((单峰-赢利)>底部,(单峰-赢利),底部);
个股散户:=IF(套牢筹码上升>顶部,顶部,套牢筹码上升),COLOR408000;
散户:IF(个股散户=DRAWNULL,DRAWNULL,个股散户),COLOR408000;
获利筹码上升:=IF((赢利-单峰)>底部,(赢利-单峰),底部);
个股主力:=IF(获利筹码上升>顶部,顶部,获利筹码上升),COLOR330088;
主力:IF(个股主力=DRAWNULL,DRAWNULL,个股主力),COLOR330088;
{--------------------换手率,五日换手率辅助判断个股活跃度-------------------}
换手:SUM(VOL,1)/CAPITAL*100,COLOR666666,NODRAW;
⑤日换:SUM(VOL,5)/CAPITAL*100,COLOR999999,NODRAW;
{----------------------密集成本突破指标筹码峰画线---操盘手公式网-----------------------}
金色背景修边1:STICKLINE(C>0 AND CURRBARSCOUNT>=2,顶部,底部,3.05,0),COLOR003333;
金色背景修边2:STICKLINE(C>0 AND CURRBARSCOUNT>=2,顶部,中轴,3.05,0),COLOR003333;
金色背景补充:DRAWBAND(顶部,RGB(51,51,0),中轴,RGB(51,51,0));
金色背景:DRAWBAND(顶部,RGB(51,51,0),底部,RGB(128,128,128));
追涨热度峰紫色:DRAWBAND(活跃度,RGB(66,52,81),底部,RGB(204,0,0));
高密峰墨蓝色:=DRAWBAND(高密,RGB(0,0,51),底部,RGB(0,0,255));
低密峰纯蓝色:=DRAWBAND(低密,RGB(0,0,102),底部,RGB(0,0,255));
90%成本峰:DRAWBAND(90%成本集中度,RGB(0,0,153),底部,RGB(0,0,153));
70%成本峰:DRAWBAND(70%成本集中度,RGB(0,128,0),底部,RGB(255,255,255));
散户峰绿色:DRAWBAND(散户,RGB(0,64,0),底部,RGB(204,0,0));
主力峰红色:DRAWBAND(主力,RGB(102,26,51),底部,RGB(0,0,255));
MACD多空趋势:DRAWBAND(MACD多头,RGB(204,51,51),空头,RGB(0,179,0));
MACD多头重画:=DRAWBAND(MACD多头,RGB(153,153,51),MACD多头,RGB(153,153,51));
MACD空头重画:=DRAWBAND(空头,RGB(0,204,0),空头,RGB(0,204,0));
{--------提供的通达信■新宝塔线■----------------}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
关闭
关闭
关闭
关闭
关闭
关闭