今日股市上证指数大盘股票行情及汇率牌价查询由操盘手公式网为您更新 大盘 上证
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 今日股市行情 今日大盘 上证指数 指标 股票 macd boll kdj obv cci rsi dmi sar vol ddx ddy
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 美元兑人民币 外汇 期货 基金 操盘手 股吧
当前位置:首页 >> 指标公式 >>  同花顺指标公式
慧眼K线指标公式同花顺主图
  • 相关简介: 今日股市
  • 内容标签: 慧眼K线指标公式,同花顺主图
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2019-11-20 09:19:33
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

慧眼K线指标公式同花顺主图,一目了然,很直观,实用,不可多得呀

{主图}

{仪表参数}

显示仪表盘1:=1;

范围高A:=REFDATE(HHV(H,120),DATE)*2.05;

范围低A:=REFDATE(LLV(L,120),DATE)*0.95;

MA5:=MA(CLOSE,5),COLORWHITE;

MA24:=MA(C,24),COLORGREEN,LINETHICK2;

MA72:=MA(C,72),COLORRED,LINETHICK2;

MA200:=IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2;

{=======================仪表盘=========================}

MA1:=MA(C,5);

主升浪:=ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);

主浪回调:=ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);

主浪深调:=ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>IF(MA200=DRAWNULL,0,MA200);

初升浪:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72;

底部反弹:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA5>MA24;

探底阶段:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA24>MA5;

观望:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24>MA72 AND C<MA72,MA72>MA200 AND C<MA200);

有牛:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C>=MA72,MA72<MA200 AND C>=MA200);

放弃:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C<MA72,MA72<MA200 AND C<MA200);

DRAWGBK(显示仪表盘1=1 AND 主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND 放弃=0,0,0,0,'观望',0)COLOR00BF00;

DRAWGBK(显示仪表盘1=1 AND 主升浪,0,0,0,'主升浪',0)COLORFF00FF;

DRAWGBK(显示仪表盘1=1 AND 主浪回调,0,0,0,'主浪回调',0)COLORFF8080;

DRAWGBK(显示仪表盘1=1 AND 主浪深调,0,0,0,'主浪深调',0)COLOR009500;

DRAWGBK(显示仪表盘1=1 AND 初升浪,0,0,0,'初升浪',0)COLOR00FFFF;

DRAWGBK(显示仪表盘1=1 AND 底部反弹,0,0,0,'底部反弹',0)COLORFFFF00;

DRAWGBK(显示仪表盘1=1 AND 探底阶段,0,0,0,'探底阶段',0);

DRAWGBK(显示仪表盘1=1 AND 观望,0,0,0,'观望',0)COLORFFFF00;

DRAWGBK(显示仪表盘1=1 AND 有牛,0,0,0,'有牛',0)COLOR00FFFF;

DRAWGBK(显示仪表盘1=1 AND 放弃,0,0,0,'放弃',0)COLOR00BF00;


{慧眼K线}

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+

15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+

10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+

5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;

马线:=MA(牛线,5);

买卖线:=MA(牛线,2);

STICKLINE(牛线>=买卖线 AND C<O,C,O,2.8,0),COLORRED;

STICKLINE(牛线>=买卖线 AND C>O,C,O,2.8,1),COLORRED;

STICKLINE(牛线>=买卖线,H,MAX(C,O),0,0),COLORRED;

STICKLINE(牛线>=买卖线,L,MIN(C,O),0,0),COLORRED;

STICKLINE(牛线<买卖线 AND C<O,C,O,2.8,0),COLORCYAN;

STICKLINE(牛线<买卖线 AND C>O,C,O,2.8,1),COLORCYAN;

STICKLINE(牛线<买卖线,H,MAX(C,O),0,0),COLORCYAN;

STICKLINE(牛线<买卖线,L,MIN(C,O),0,0),COLORCYAN;

DRAWICON(CROSS(牛线,买卖线),L*0.99,7);

DRAWICON(CROSS(买卖线,牛线),H*1.01,8);

主力成本线:牛线,COLORYELLOW;

资金生命线:马线,COLORRED;

水平面:MA(C,60),COLORGREEN;

{公司信息}

利润同比:=STRCAT('利润同比:',CON2STR(FINANCE(43),2));

收入同比:=STRCAT('收入同比:',CON2STR(FINANCE(44),2));

主营利润率:=STRCAT('主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));

所属地域:=STRCAT('所属地域:',DYBLOCK);

所属行业:=STRCAT('所属行业:',HYBLOCK);

所属概念:=STRCAT('所属概念:',GNBLOCK);

所属风格:=STRCAT('所属风格:',FGBLOCK);

主营业务:=STRCAT('主营业务:',EXTERNSTR(0,1));

DRAWTEXT_FIX(1,0.08,0.01,0,利润同比),COLORWHITE;

DRAWTEXT_FIX(1,0.19,0.01,0,收入同比),COLORMAGENTA;

DRAWTEXT_FIX(1,0.30,0.01,0,主营利润率),COLOR0080FF;

DRAWTEXT_FIX(1,0.08,0.06,0,所属地域),COLORYELLOW;

DRAWTEXT_FIX(1,0.08,0.11,0,所属行业),COLORYELLOW;

DRAWTEXT_FIX(1,0.08,0.16,0,所属概念),COLORYELLOW;

DRAWTEXT_FIX(1,0.08,0.21,0,所属风格),COLORCYAN;

{主力散户进出}

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=L2_AMO(0,3)/10000.0;

大S:=L2_AMO(1,3)/10000.0;

中S:=L2_AMO(2,3)/10000.0;

小S:=L2_AMO(3,3)/10000.0;

TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

主力进:=(超B)+(大B),NODRAW;

主力出:=(超S)+(大S),NODRAW;

小散进:=(中B)+(小B),NODRAW;

小散出:=(中S)+(小S),NODRAW;

DAZHIV:=CONST(MAX(ABS(主力进),MAX(ABS(主力出),MAX(ABS(小散进),ABS(小散出))))),NODRAW;

DRAWRECTREL(0,CONST(940-(ABS(主力进)*250/DAZHIV)),30,960,IF(CONST(主力进>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(32,CONST(940-(ABS(主力出)*250/DAZHIV)),62,960,IF(CONST(主力出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(70,CONST(940-(ABS(小散进)*250/DAZHIV)),100,960,IF(CONST(小散进>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(102,CONST(940-(ABS(小散出)*250/DAZHIV)),132,960,IF(CONST(小散出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(主力进/10,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.033,0.9,0,STRCAT('',CON2STR(主力出/10,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.07,0.9,0,STRCAT('',CON2STR(小散进/10,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.101,0.9,0,STRCAT('',CON2STR(小散出/10,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.03,1,0,'(X10万元)'),COLOR00FFFF;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,1,0,'主进出'),COLORCYAN;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.09,1,0,'散进出'),COLORCYAN;

主力买力度:=LARGEINTRDVOL*1000/VOL;

主力卖力度:=LARGEOUTTRDVOL*1000/VOL;

AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

DRAWRECTREL(0,515,CONST(ABS(主力买力度)*500/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*500/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));

DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;

用法详细说明:仪表K线可以快速辅助判断个股状态,需要把BMP图片解压后复制到\T0002\signals 文件夹。
第一次发帖多多支持,谢谢大家,得到大家的认可会把一个自用多年的量价指标分享给大家,可以显示到主图,也可以编辑选股指标,成功率很高。慧眼K线主图
指标,个人添加仪表盘(配合BMP图片,图片在二楼),主力小股民资金进出(需登录L2行情),个股基本资料(公司业绩、所属风格、概念、行业、地域)。配合倍量柱、筹码锁定、机构控盘度来发掘主力意图。

版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
关闭
关闭
关闭
关闭
关闭
关闭