实时为您更新上证股市大盘及汇率数据 大盘 上证
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 今日股市行情 今日大盘 上证指数 指标 股票 macd boll kdj obv cci rsi dmi sar vol ddx ddy
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 美元兑人民币 外汇 期货 基金 操盘手 股吧
/
当前位置:首页 >> 选股公式 >>  选股公式大全
选股公式源码大全
  • 相关简介: 今日股市
  • 内容标签: 选股公式源码大全
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2020-03-05 21:14:23
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

选股公式源码大全,基本上包括所有的选股公式,可随意自己组合,无论是小白还是高手都用的到, 收藏是你的损失,附公式导入方法详解。

        一个简单的条件选股公式编写选股公式,要求选出“股价回抽20日均线选股公式”的股票,可以在选股公式源码大全里头去挑选你想要的:

1.打开公式管理器,创建一个新的条件股票选择公式,依次点击菜单“函数一个专家系统一个公式管理器”,进入公式管理器界面。

2.在左边的树型列表中选择条件股票选择公式下面的其他类型,然后单击New,如下所示:

输入公式名称,选股公式源码大全中找到你想要的选股公式源码

编辑区域如下:公式源码如下:xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c); 复制到空白框内

3.输入“公式名称”,比如“回抽20日选股”,点击“确定”

4.点击“测试公式”,如果显示测试通过,点击“确定”按钮保存公式..

这样你的回抽20日选股公式就导入成功了,接下来 就可以选股了,祝你好运!

选股公式源码大全

      我们都在股票软件中,背后有一个庞大的数据库,它保存着股票市场以来所有股票的有用数据,如收盘价、最高价格、最低价格、开盘价等。 股东可以选择自己的K线走势来选择,也可以根据自己的要求通过设计一个功能公式来找到自己想选择的股票,这个公式我们称之为http://www.stock87.com/index.php?c=content&a=list&catid=46选股公式.. 如果你在寻找股价低于10元的个股,你只需要设定一个公式,好了,下面送出“选股公式源码大全”http://www.stock87.com/index.php?c=content&a=show&id=12766.

选股公式源码大全:(如此珍贵的选股公式源码记得收藏好!)

选股公式源码大全

1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;3;3。
2.
选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日线以上.
cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);

3. KD指标产生黄金交叉,K线上穿D线。
4. KD交叉同时,KD指标中的D值要小于16。
BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
xg:BIAS3<-6 and cross(k,d) and d<16;
5,今天的量 是5天平均的 2倍以上
xg:v>ma(v,5)*2;
缩量
vol/ma(vol,10)<0.3;
6,两天内,累计下跌等于或超过20%选股.
xg:(ref(c,2)-c)/c>0.2;

7, BIAS指标要小于-6,这只是确认该股超跌的初选条件。

8,个股分时图上都有一条黄线,叫做均价线
a/capital*100;
9,"阴转阳"的公式(也就是昨天收阴线,今天收阳线)
xg:ref(c,1)o;
{操盘手公式网-专业指标公式网 www.stock87.com}

10,股价回抽20日均线选股公式
xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);
11,一根大阳线,至少有5个点以上,再连着出现二根振幅不大于5的十字星或是小K
线
xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;
12,
要求是量大、换手率达到3左右,涨幅>7个点。
xg:v/capital*100>3 and (c/ref(c,1)>1.07;13,kdj的J从上向下穿越O轴发出信号
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
xg:cross(0,j);
14,
行情信息里的“涨幅”的原码
(c-ref(c,1))/c*100;15,选出10天内出现了涨停的个股
count(c/ref(c,1)>1.1,10)>0;
又:
今涨停:=C/REF(C,1)>1.09;
选股:count(今涨停,n);
16,一阳上穿10,20,30日线,量能是前一天3倍。
xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and
v>ref(v,1)*3;
{操盘手公式网-专业指标公式网 www.stock87.com}

17,股价4天中有两天在10日线上
count(c>ma(c,10),4)=2;18,选出今日成交量大于昨日成交量一成的股票。
xg:v>ref(v,1)*1.1;
19,连续5天,当日的5日均线减前一天的5日均线差值小于1.
count((ma(c,5)-ref(ma(c,5),1))<1,5)=5;
20,股价上穿5周均线:
xg:cross(c,ma(c,5));
注意:选股时用周线
21,
共三根K线,第一根K线为阴线;第二根K线为阴线线,最高价低于第一根K线
,最低价高于第一根K线;第三根K线阴阳不限,最高价低于第二根K线,最低价高
于第二根K线。满足后发出信号~
w1:=ref(c,2)
w2:=ref(h,2)>ref(h,1) and ref(l,2)
w3:=ref(h,1)>h and ref(l,1)
xg:w1 and w2 and w3;22,两笔阴线中间夹着一根阳线或数根K线,其中两笔阴线最低点相等
xg:ref(l,2)=l;
23,
上穿30日均线的公式
xg:cross(c,ma(c,30));24,换手:VOL*100/CAPITAL;
周期换手:SUM(换手,10);
25,流通盘小于4000万的选股公式
xg:CAPITAL/100<4000;
{操盘手公式网-专业指标公式网 www.stock87.com}

26,量比大于1 同时换手大于2的公式
xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;27,当天开盘价与收盘价相等的选股公式
xg:c=o;
28,
涨停开盘跌停收盘选股
xg:h/ref(c,1)>1.1 and ref(c,1)/l>1.1;

29,收下影线
xg:c>l;
30,
5日均线向上流通盘小于5000万 换手率大于3的选股公式
lt:CAPITAL/100<5000;
换手:=VOL*100/CAPITAL<3;
w1:ma(c,5)>ref(ma(c,5),1);
xg:lt and 换手 and w1;

31,当日收盘下穿5日均价
xg:cross(ma(c,5),c);
32,最低价小于前一日的最低价但收盘后为阳线。
xg:lo;
{操盘手公式网-专业指标公式网 www.stock87.com}

33,o=l就没有下引线了,那就:
xg:c>l and o>l;34,选周线跳空缺口的个股。
xg:HIGH
LOW>REF(HIGH,1);
周期选周线
35,
30日内到本日收盘价下跌20%的公式
xg:hhv(c,30)/c>1.2;36,连续4天的收盘价格波动幅度在3%之内连续走平或向上
count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;
37,下影线长于上影线
(c-l)>(h-c);
38,
30日均线走平或走高的个股
xg:ma(c,30)>ref(ma(c,30),1);

39,今天高开的公式
c>o;
40,今天的量大于等于昨天量的2倍,股价上涨
xg:v>ref(v,1)*2 and c>ref(c,1);
{操盘手公式网-专业指标公式网 www.stock87.com}

41,收盘价+收盘价的10%
(c+c*0.1);42,31天均线向上的股
xg:ma(c,30)>ref(ma(c,20),1);
43升降幅在-n%----n%之间
w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100
44,
今天的量小于昨天量的2倍以上,股价上涨
xg:vref(c,1);45,60个交易日内,涨幅大于9.9%(涨停)的天数
count(c/ref(c,1)>1.099,60);
46,昨天跌幅大于3%,今天开盘高开2%以上的选股公式。
xg:ref(c,1)/ref(c,2)<0.97 and o/ref(c,1)>1.02;
47,
"今日MACD等于昨天的MACD ,且macd>0" 的指标
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
xg:macd=ref(macd,1) and macd>0

选出周换手率小于10%的股票
sum(VOL/CAPITAL*100,5)<10;
48,
换手率10天30%以上的选股公式
sum(VOL/CAPITAL*100,10)>30;xg:v=llv(v,20) and c=llv(c,20);
49,5日不涨,绿线收盘选票指标
count(c
50,
成交量创20日新低,并且股价也创20日新低51,连续2天收盘价跌破30日均线,就显示"卖出"信号
a1:count(c
drawtext(a1,c,卖出),colorgreen;
52,股票在这条均线上在8天以上,上下幅度不大,
a1:abs((c-ma(c,120))/ma(c,120))<0.1;
xg:count(a1,8)=8;
53,
连续3天每天的最低价都比前一天高
count(l>ref(c,1),3)=3;
54,n天内曾经有m个涨停
count(c/ref(c,1)>1.09,n)>m;
{操盘手公式网-专业指标公式网 www.stock87.com}

55,股价比昨天的高,量比昨天小,放量。
xg:c>ref(c,1) and vref(v,2)*2;
56,
连续三天高开高走的选股公式
count(o>ref(c,1) and c>o,3)=3;57,周量缩小50%或40%或n%
a1:vol/capital*100;
xg:a1/ref(a1,1)
58,股价超过五日均价的15%以上,并给出卖出信号
卖出:c/ma(c,5)>1.15;
59,连收两个十字星的选股公式
count(abs((c-o)/o<0.01),2)=2;
60
,振幅大于5%,收盘价大于3.5小于15元,三日均线大于昨日的三日均线,去掉
ST股。
a1:=h/l>1.05;
a2:=c>3.5 and c<15;
a3:=ma(c,3)>ref(ma(c,3),1);
xg:a1 and a2 and a3;
{操盘手公式网-专业指标公式网 www.stock87.com}

61,收盘价连续8天都站在5日均线的股票。
count(c>ma(c,5),8)=8;
62,
n横盘天数,n1横盘的上下幅度
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)
and ref(v,1)

63,收盘价下有60天前的远期获利盘n%。
{60天前的远期获利盘:=ppart(60)*100;}
aa:WINNER(ref(c,60 ))*100;
64,
股价突破5ma买入,跌破5ma卖出。买入和卖出用箭头表示 (副图)
a1:cross(c,ma(c,5));
a2:cross(ma(c,5),c);
drawtext(a1,low*0.98,↑),colorred;
drawtext(a2,h*1.02,↑),color00ffff;
65,昨日收阴,今日收阳,的K线组合。
C>O AND REF(C,1)
66,
连续三日收阳后日收盘高于前日 且每日收于当日最高价附近 每日涨幅不大于4%
选股:count(c>o and c>ref(c,1) and abs((h-c)/c)<0.01 and c/ref(c,1)
<1.04,3)=3;67,20天均线向上的股
xg:ma(c,20)>ref(ma(c,20),1);
{操盘手公式网-专业指标公式网 www.stock87.com}

68,历史高点到前一高点画线
POLYLINE(h>=hhv(c,0),h);
69,均线中增加一根线,这根线的价格是5日线的1.2倍
aa:ma(c,5)*1.2;
70,
今天的250平均线大于昨天的昨天的250平均线
ma(c,250)>ref(ma(c,250),1);71,连续3天收盘全是阴线。
count(c
72,今天收盘价在昨天收盘价-2%~2%之间
c/ref(c,1)>0.98 and c/ref(c,1)<1.02;
73,
一条均线18MA 股价上涨后“缩量”回调到18MA
XG:COUNT(VMA(C,18);
N “缩量”回调的天数
74,N天前换手率大于8%
REF(VOL/CAPITAL*100,N)>8;
75,
收盘价在5日均线以上5天
count(c>ma(c,5),5)=5;76,1。昨日量是n天以来最低量,(n可调);2。今日量是昨日量的m倍,(m可
调);3。今日k线收阳线;
xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;
77,
最近3天(包括昨天.前天)股价突破250日均线
COUNT(C>MA(C,250),3)=3;78,月k线十字星收盘并且5月线拐点向上。
XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);
用月线选股
79,
第一天收阴,第二天,第三天,第四天,收出红三兵
XG:REF(C,3)O,3)=3;
{操盘手公式网-专业指标公式网 www.stock87.com}

80,跳高大阴线,条件: 1 开盘跳空4%以上2 大阴线实体6%以上.
O/REF(C,1)>1.04 AND C/REF(C,1)<0.94;
81,
5日均线倾角大于60度X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
也可以这样:
X:(ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*180/3.14115926)>60;利用指标排
序:X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
82,60与120均线距离在n%内
XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))
83:
条件:1: 假设大前天创最近新高,要求这天涨幅是超过7%的大阳线,且创最近一个月的新高.
2: 那么前天,昨天,今天都收小K线,要求小K线实体
xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref
(c,1))/ref(c,1)<0.02,3)))=3;84,昨日前日涨停的REF(C,1)/REF(C,2)>1.095;
85,count(x,n) 意思是n天内出现过信号的,假设n=10,那么就是10天内出现信
号(包括今天),如果不加这个的话,就是限定在今天出信号才选出来,以前的
不管。
86,今天涨停的公式C/REF(C,1)>1.09;
87,10日内有涨停的公式今涨停:=C/REF(C,1)>1.09;
选股:count(今涨停,10);
88,
“中阴之后,跳拉阳”c/ref(c,1)>1.05;89,近5日K线最高价和最低价格波动在10%以内,成交量是昨日2倍,收盘涨5%
XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)
>1.05;
90,60与120均线距离在n%内XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))
91,“中阴之后,跳拉阳”c/ref(c,1)>1.05;
{操盘手公式网-专业指标公式网 www.stock87.com}

92,能在图上提示个股(不含S或ST股)出现过的涨跌停板日期的公式
w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);
93,涨幅≤2%(c-ref(c,1)/ref(c,1)*100<2;
94,
(1)换手率均线DMA(c ,v/CAPITAL );

(2)20天以来的任意天期
(n),换手率均线正负波动值<=p%;
AA:=DMA(c ,v/CAPITAL );
ab:=(aa-ref(aa,1))/ref(aa,1)*100

bb:count(ab,20)>=n;

95,5日,10日,30日贴近公式,越贴越好
m1:=ma(close,5);
m2:=ma(close,10);
m3:=ma(close,20);
m4:=ma(close,30);
y1:=max(max(max(m1,m2),m3),m4);
x1:=min(min(min(m1,m2),m3),m4);
黏合:y1/x1
n越小越黏合(n,1.01-----1.05)

96, 30天线拐头向上出现提示
ma(c,30)>ref(ma(c,30),1);
97,
K线沿着5日均线往上爬的选股公式w1:ma(c,5);
w2:abc(c-w1)/w1<0.01;
xg:count(w1>ref(w1,1),5)=5 and w2;

98,今天的换手率大于前天的一倍以上
w1:=v*100/capital;
w1>ref(w1,2)*2;

99,20日均线,上穿62日均线
xg:cross(ma(c,20),ma(c,62));
100,
选出当日最低价在10日均线上下0.05%内,收盘价在均线上方的个股
abs(l-ma(c,10))<0.005 and c>ma(c,10);
101,选出当日收盘价突破10日均线5%的个股
cross(c,ma(c,10)*1.05);
{操盘手公式网-专业指标公式网 www.stock87.com}

102,平台整理的公式,整理时间和整理幅度可调
COUNT(CLOSE,0)>N AND
(HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);
N整理时间,N1整理幅度103,第一天股票涨停,第二天成交量是第一天成交量的1倍,并超过10%.那第三天
就是买点
w1:=ref(c,2)/ref(c,3)>1.1;
w2:=ref(v,1)/ref(v,2)>2;
xg:w1 and w2;
104,放量2倍突破300日线的选股指标
cross(c,ma(c,300)) and v>ref(v,1)*2;
105,
,昨天升降幅在-n%----n%之间
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
w1:=cross(ma(c,3),ma(c,10));
xg:w1 and cross(k,d);
106,
3日均线上穿10日均线,KDJ有效金叉
107,连续3-5天,每天的收盘价涨跌幅不超过1%.w1:abs(c-o)<0.01;
xg:count(w1,5)>=3;
108
30日均线拐头向上ma(c,30)>ref(ma(c,30),1);w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100
109,MACD在8天以内两次金叉DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
w1:cross(DIFF,dea);
xg:count(w1,8)>=2;
{操盘手公式网-专业指标公式网 www.stock87.com}

110,K线收十字星abs(c-o)/o<0.01;

111,,涨停过300日线的选股公式
w1:abs(c-ma(c,20)/ma(c,20)*100<2;
N日均线相差M个百分点的公式.
w1:abs(c-ma(c,n)/ma(c,n)*100
n:N日 m:M个百分点
112,60MA由向下调头向上ma(c,60)>ref(ma(c,60),1);
113, 股价回调到14日均线的选股
abs(c-ma(c,14))/ma(c,14)<0.005;
114,历史第5根K线到第30根K线之间的最高价hhv(ref(c,5),25);
115,和
20日均线相差2个百分点的DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
拐点:ref(macd,2)>ref(macd,1) and ref(macd,1)
116,跳空高开收阳线LOW>REF(HIGH,1) and c>o;
117,
MACD的拐点公式DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));

    c/ref(c,1)>1.09 and cross(c,ma(c,300));
118,成交量是前5天中其他任何一天的10天均量线的3.5倍以上
w1:=llv(ma(v,10),5);
xg:v>w1*3.5;
119,
连续n天收阳线UP:=CLOSE>OPEN;
COUNT(UP,N)=N;
xg:count(w1,n)=n;
120,跳空高开后,三天内没有回补缺口
ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);
121,
{5日均线倾角大于60度}
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
122,股价创30个交易日的新高H>ref(H,30);
{操盘手公式网-专业指标公式网 www.stock87.com}

123,股价N天内连续沿着5天线走,且每天收盘价与5天线的距离不超过2%的选股公式
w1:=abs(c-ma(c,5))/ma(c,5)<0.02;124, {5日内第二大量}
zdl:=hhv(v,5);
v0:=IF(v>=zdl,0,v);
v1:=IF(ref(v,1)>=zdl,0,ref(v,1));
v2:=IF(ref(v,2)>=zdl,0,ref(v,2));
v3:=IF(ref(v,3)>=zdl,0,ref(v,3));
v4:=IF(ref(v,4)>=zdl,0,ref(v,4));
第二大量:MAX(MAX(MAX(MAX(v0,v1),v2),v3),v4);
DRAWTEXTABS( 0,10 ,第一大量 + zdl+ 第二大量+第二大量);同理可求出第三大
、第四大和最小量.实行简单的排列.
125,
日涨幅小于3%C>0 AND C/REF(C,1) >1.03;

126,30个交易日内,股价跌幅达到一半的股票:
xg:(hhv(c,30)-c)/hhv(c,30)>0.5;

     好了文章篇幅有限,先发这么后续有机会,有股友需要我们会继续添加,大家自行DIY.

选股公式源码大全:http://www.stock87.com

版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
关闭
“炒股公式”width="120"
关闭
“抄底公式”
关闭
关闭
关闭
关闭