今日股市上证指数大盘股票行情及汇率牌价查询由操盘手公式网为您更新 大盘 上证
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 今日股市行情 今日大盘 上证指数 指标 股票 macd boll kdj obv cci rsi dmi sar vol ddx ddy
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 美元兑人民币 外汇 期货 基金 操盘手 股吧
当前位置:首页 >> 指标公式 >>  大智慧指标公式
百步穿扬指标编写选股公式
  • 相关简介: 今日股市
  • 内容标签: 指标编写选股公式
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2020-03-11 08:59:48
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

百步穿扬指标编写选股公式,那么有很多人就问了,指标为什么起名叫:百步穿扬。是根据古代典故来的:

玉吉是春秋时期楚国著名的将军,也是中国古代著名的神射手。 具体出生时间不详,大致出生于公元前七世纪,英姓,阳姓.. 后来,被楚国吞并后,养国就住在楚国。 关于他的射箭可以说是百次,百步穿扬指标,而这两个成语,其实也都与基础有关.. 玉姬擅长射箭,他能在离柳树一百步远的地方射箭,每一支箭都能击中柳叶的中心,射击一百次就能击中一百次。

楚共王16年(公元前575年)6月28日,晋国之间的战斗,楚延陵,晋军将军吕震射在楚共王眼中.. 楚王召见玉姬,给他两箭射陆.. 被基地举射中的陆\27780;脖子,陆\27780;伏倒在弓上死了.. 他带着剩下的家人,回到了楚王身边..“百步穿杨,百发百中”这个典故,百步穿扬指标就是这样定义的。

 这两个成语都是出自这个典故,虽然没有进一步的描写,但相信杨雨霁听了这位路人的话,学会了调整气息,射箭必将更上一层楼.. 而从未来由基地升起前进了很多箭,当时应该已经听了这位路人的建议,调整了气息,所以在以后的战斗中杀敌,虽然几支箭,还是可以百倍,也为楚军树立了很多汗水。

百步穿扬指标

百步穿扬指标公式http://www.stock87.com/index.php?c=content&a=list&catid=2源码:

BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
底背离:IF(MN<-4 ,17,0),COLORA67D3D,LINETHICK3;
顶背离: IF((VAR26>90),17,0), COLOR6B238E,LINETHICK3;
IF(MN<-4 ,12,0),COLORBLACK,LINETHICK3;
IF((VAR26>90),12,0), COLORBLACK,LINETHICK3;
DRAWTEXT(顶背离,6,'顶背离'),COLORGREEN;DRAWTEXT(底背离,6,'底背离'),COLORA67D3D;
N:=20;
MID:=MA(C,N);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:=REF(MID,1);
UB:=REF(UPPER,1);
LB:=REF(LOWER,1);
LOWER1:=MID-VART3;
LB1:=REF(LOWER1,1);
股价线:(C-LB1)/(UB-LB)*100,COLORGREEN, LINETHICK1;

{操盘手公式网-专业指标公式网 http://www.stock87.com}

趋势线:MA(股价线,6),COLORRED, LINETHICK3;

90,COLORGREEN, LINETHICK1;
50,COLORWHITE, LINETHICK1;
0,COLORWHITE, LINETHICK1;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
准备建仓:EMA(IF(L<= LLV(L,30),VARC,0),3),COLORFF00FF,LINETHICK2;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLORFFFF00,LINETHICK3;
IF((VARO7<10),85,100) ,COLORBLACK,LINETHICK2;
下单: IF(CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10),38,0),STICK ,COLORYELLOW, LINETHICK4;
DRAWTEXT(下单,38,'下单!'),COLORGREEN;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离1:=MA(BIAS,3);
乖离:IF(CROSS(BIAS,乖离1) AND 乖离1<-9,28,0),COLORRED,LINETHICK2;
IF(CROSS(BIAS,乖离1) AND 乖离1<-9,18,0),COLORRED,LINETHICK2;
DRAWTEXT(乖离,18,'低买'),COLORRED;

STICKLINE(CROSS(BIAS,乖离1) AND 乖离1<-9,-12,0,6,0),COLORYELLOW;

TRJ:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);

HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
神偷线:=(((DMP ) * 100) / TRJ);
辅助线:=((DMM * 100) / TRJ);
动向趋势线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3));
ADXR:=((动向趋势线 + REF(动向趋势线,3)) / 2);
VAR3:=MA(CLOSE,2);
VAR7:=REF(VAR3,1);
【强弱】:=((SMA(MAX((VAR3 - VAR7),0),5,1) / SMA(ABS((VAR3 - VAR7)),5,1)) * 100);
快买:( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),68,0)),LINETHICK1,COLORFF00FF;
( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),48,0)),LINETHICK1,COLORFF00FF;
DRAWTEXT(快买,60,'准备'),COLORFF00FF;
MA2:=EMA(C,2);MA5:=EMA(C,5);MA13:=EMA(C,13);MA30:=EMA(C,30);MA55:=EMA(C,55);YCX:=MA5>=REF(MA5,1);H1:=MAX(MAX(MA5,MA13),MA30);L1:=MIN(MIN(MA5,MA13),MA30);一阳穿三线:= H1<C AND O<L1 AND YCX AND MA2>REF(MA2,1);满仓选股:IF(一阳穿三线,88,0),COLORFFFF00,LINETHICK2;
IF(一阳穿三线,58,0),COLORFFFF00,LINETHICK2;
DRAWTEXT(一阳穿三线,88,'满仓'),COLORYELLOW;
VAR2:=0.0001*AMOUNT,;
MA1:=0.0001*MA(AMOUNT,5);

M2:=0.0001*MA(AMOUNT,10);

DRAWTEXT(百日地量,-10,'地量'),COLORRED;

百日地量:LLV(VAR2,100)=VAR2,STICK,COLORRED,LINETHICK0;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {选股设JC=10即可}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
JC:IF(SSS-SSB=2 AND SSS>REF(SSS,1),-22,0),LINETHICK2,COLORFFFF00;
IF(SSS-SSB=2 AND SSS>REF(SSS,1),-12,0),LINETHICK2,COLORFFFF00;
DRAWTEXT(A1,-10,'W底'),COLORYELLOW;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
V1:(CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03)
OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05
AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035));
IF(V1,28,0),COLORYELLOW,LINETHICK2;
IF(V1,18,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(V1,28,'买点'),COLORRED;
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击选股:FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
青云直上选股:IF(FILTER(MR,10),30,0),COLORYELLOW,LINETHICK2;
IF(FILTER(MR,10),20,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(青云直上选股,30,'青云直上'),COLORGREEN;
QUAN:(CLOSE-DMA(CLOSE,VOL/SUM(VOL,13)))/DMA(CLOSE,VOL/SUM(VOL,13))*100<=-28 AND (CLOSE-DMA(CLOSE,VOL/SUM(VOL,34)))/DMA(CLOSE,VOL/SUM(VOL,34))*100<=-19
AND C/REF(C,25)<=1.1 AND IF((((HIGH > (LOW * 1.051)) AND (COUNT((HIGH > (LOW * 1.051)),5) > 1)) AND ((((CLOSE / MA(CLOSE,40)) * 100) < 78) OR
(((CLOSE / MA(CLOSE,60)) * 100) < 74))),2,0) AND
(SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)<15 AND IF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)>REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)
AND REF(SMA((CLOSE-LLV(LOW,8))/
(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)<REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),2)
AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)<23 ,1.5,0) AND FILTER((C/MA(C,48))<0.75 AND (C/MA(C,70))<0.70 AND
((C-L)/C>0.02 OR C>REF(C,1)*1.01) AND V<REF(V,1)*2.8 AND (COUNT(C<O*0.93,2)=2 OR COUNT(H/L>1.1,5)>3),3) ;
DRAWTEXT(QUAN,88,'弱市百步穿扬'),COLORFFFF00;
IF(QUAN,88,0),COLORFFFF00,LINETHICK2;
IF(QUAN,60,0),COLORFFFF00,LINETHICK2;
AA:=1;
BB:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
CC:=IF(AMOUNT/C/HHV(AMOUNT,9)/HHV(C,9)*100>100,100,AMOUNT/C/HHV(AMOUNT,9)/HHV(C,9)*100);
DD:=CC/BB;
顶部雷达:CROSS(80,RSI)*88,LINETHICK2 ,COLORGREEN;
CROSS(80,RSI)*58,LINETHICK2 ,COLORGREEN;
DRAWTEXT(CROSS(80,RSI),88,'逃顶 '),COLORGREEN;

百步穿扬选股公式源码:
MA2:=EMA(C,2);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
MA30:=EMA(C,30);
YCX:=MA5>=REF(MA5,1);
H1:=MAX(MAX(MA5,MA13),MA30);
L1:=MIN(MIN(MA5,MA13),MA30);
{操盘手公式网-专业指标公式网 http://www.stock87.com}XG:H1<C AND O<L1 AND YCX AND MA2>REF(MA2,1);


百步穿扬指标公式:http://www.stock87.com

版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
关闭
关闭
关闭
关闭
关闭
关闭