今日股市上证指数大盘股票行情及汇率牌价查询由操盘手公式网为您更新 大盘 上证
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 今日股市行情 今日大盘 上证指数 指标 股票 macd boll kdj obv cci rsi dmi sar vol ddx ddy
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 美元兑人民币 外汇 期货 基金 操盘手 股吧
当前位置:首页 >> 指标公式 >>  通达信指标公式
通达信股票公式 慢速KD指标融合macd合适短线中线操盘
  • 相关简介: 今日股市
  • 内容标签: 通达信
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2022-07-05 22:35:50
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

通达信股票公式 慢速KD指标融合macd合适短线中线操盘

N:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORBLUE;
DRAWTEXT(C>=MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),' 黄色持股 (短线)'),COLORYELLOW;
DRAWTEXT(C<MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),' 蓝色持币 (短线)'),COLORFF9933;
M:=IF(BARSCOUNT(C)>=45,45,BARSCOUNT(C));
STICKLINE(C>=MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORBLUE;

DRAWTEXT(C>=MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),' 黄色持股 (中线)'),COLORYELLOW;

DRAWTEXT(C<MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),' 蓝色持币 (中线)'),COLORFF9933;
DRAWKLINE(H,O,L,C);
MA5:MA(C,5),COLORMAGENTA;
MA10:MA(C,N),COLORLIRED;
MA25:MA(C,25),LINETHICK2,COLORRED;
MA45:MA(C,M),COLORGREEN;
MA120:MA(C,120),COLORBROWN;

本只偏重于短线操盘,我把慢速KD也组合进去后,也就兼顾了中线操盘。下面是操盘手公式网老师改良后的源码,个人更喜欢改良后的版本,感谢老师!
Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
波段进场:IF(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2),80,50);
反弹进场:IF(REF(VAR4,1)<5 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND VAR3<-0.3,80,50);
超跌进场:IF(CROSS(VAR4,5) AND VAR3<-0.4,80,50); STICKLINE(C>=MA(C,10),VAR4,REF(VAR4,1),4,0),COLORRED; STICKLINE(C<MA(C,10),VAR4,REF(VAR4,1),4,0),COLORGREEN;
RSV:= (CLOSE-LLV(LOW,50))/(HHV(HIGH,50)-LLV(LOW,50))*100;
FASTK:=SMA(RSV,3,1);
SK:SMA(FASTK,3,1),LINETHICK2,COLORYELLOW;
SD:SMA(SK,5,1),LINETHICK2,COLORMAGENTA;
MAKD:=(SK-SD)*2;
STICKLINE(MAKD>0 AND REF(MAKD,1)<MAKD,50,MAKD+50,0,0),COLORRED;
STICKLINE(MAKD>0 AND REF(MAKD,1)>MAKD,50,MAKD+50,0,0),COLORLIRED;
STICKLINE(MAKD<0 AND REF(MAKD,1)>MAKD,50,MAKD+50,0,0),COLORLICYAN;
STICKLINE(MAKD<0 AND REF(MAKD,1)<MAKD,50,MAKD+50,0,0),COLORLIGREEN;

版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网


浙ICP备17017803号-1
关闭
关闭
关闭
关闭
关闭
关闭