股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  公式教程答疑
股票配资开户注册领取2019元现金
牧客农场-注册送50金币
请操盘手公式网老师把分析家箱体公式改成通达信的
  • 相关简介: 测试已通过
  • 内容标签:
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2017-09-11 00:25:36
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

编写要求:

请操盘手公式网老师把分析家箱体公式改成通达信的,源码如下: DRAWGBK(close=close, STRIP(RGB(10,190,255),RGB(255,155,155),0)); VarA:=IF(CLOSE>150,91.3,0.913); 箱下沿:INTPART(CLOSE/VarA )*VarA,pointdot,linethick3,colorgreen; 箱上沿:箱下沿+VarA,pointdot,linethick3,coloryellow ; 箱中线:(箱下沿+箱上沿)/2,pointdot,colorwhite,linethick3; 走势: SMA(FORCAST(CLOSE,18),6,1),COLOR0066cf,LINETHICK2; FILLRGN(走势,走势-0.06,走势>REF(走势,1) ),COLORff00ff; var1:=(SMA(HIGH,21,2) * 1.05); Var2:=IF(C/REF(C,1)>1.050 AND V/CAPITAL*100<10 AND C<17 AND H/C<1.01 AND VarA>0, 91, 0); STICKLINE(Var2>90,L*0.99,L*0.96,5,0),COLORYELLOW; DRAWTEXT(Var2>90,LOW*0.98,' 追'),COLORYELLOW; V1:=EMA(EMA(EMA(C,8),13),55); V2:=(REF(H,1)+REF(L,1))/2; V3:=MA(C,20)+2*STD(C,20); DRAWTEXT(CROSS(V2,V3),HIGH*1.06,'→卖'),COLORblue; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00; STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000A3; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000B7; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000CD; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000E9; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754E9; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076EF3; STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color077BF3; STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726CA; STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726CA; STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100; STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,9,0),color0090FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,8,0),color009FFF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,4,0),color00B5FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2,0),color00E4FF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,0.7,0),color00FFFF; STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0.7,0),color00FFFF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),OPEN,LOW,0.7,0),colorFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,HIGH,0.7,0),colorFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,9,0),colorFF00FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,6,0),colorFF62FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,4,0),colorFF76FF; STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,2,0),colorFFA8FF;

操盘手公式网官方签约公式老师专业解答源码如下:

VARA:=IF(CLOSE>150,91.3,0.913);

箱下沿:INTPART(CLOSE/VARA )*VARA,CIRCLEDOT,COLORGREEN;
箱上沿:箱下沿+VARA,CIRCLEDOT,LINETHICK1,COLORYELLOW ;
箱中线:(箱下沿+箱上沿)/2,CIRCLEDOT,COLORWHITE,LINETHICK1;
走势: SMA(FORCAST(CLOSE,18),6,1),COLOR0066CF,LINETHICK2;
IF(走势>REF(走势,1),走势,DRAWNULL),COLORFF00FF,LINETHICK3;
VAR1:=(SMA(HIGH,21,2) * 1.05);
VAR2:=IF(C/REF(C,1)>1.050 AND V/CAPITAL*100<10 AND C<17 AND H/C<1.01 AND VARA>0, 91, 0);
STICKLINE(VAR2>90,L*0.99,L*0.96,5,0),COLORYELLOW;
DRAWTEXT(VAR2>90,LOW*0.98,' 追'),COLORYELLOW;
V1:=EMA(EMA(EMA(C,8),13),55);
V2:=(REF(H,1)+REF(L,1))/2;
V3:=MA(C,20)+2*STD(C,20);
DRAWTEXT(CROSS(V2,V3),HIGH*1.06,'→卖'),COLORBLUE;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3,0),COLORFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2.5,0),COLORFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2,0),COLORFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),COLORFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1,0),COLORFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0.5,0),COLORFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0,0),COLORFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),COLOR070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2.5,0),COLOR0000A3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),COLOR0000B7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),COLOR0000CD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),COLOR0000E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0.5,0),COLOR0754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0.2,0),COLOR076EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0,0),COLOR077BF3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0,0),COLOR0726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0,0),COLOR0726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,0,0),COLORDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,0,0),COLORDE9100;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,3,0),COLOR0090FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2.5,0),COLOR009FFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2,0),COLOR00B5FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,1.5,0),COLOR00E4FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,1,0),COLOR00FFFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < VAR1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0.5,0),COLOR00FFFF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),OPEN,LOW,0,0),COLORFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,HIGH,0,0),COLORFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,3,0),COLORFF00FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,2.5,0),COLORFF62FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,1.5,0),COLORFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > VAR1)) AND (CLOSE < VAR1)),CLOSE,OPEN,0,0),COLORFFA8FF;

扫码关注直播抓黑马⇓  点击进入老师新浪博客⇓  


下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
官方千人交流微信群1:antu1688
官方千人交流微信群2:1500113880



关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2018   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭