股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  飞狐公式
股票配资开户注册领取2019元现金
牧客农场-注册送50金币
飞狐上升通道强势股主图指标
  • 相关简介: 测试已通过
  • 内容标签: 强势股,通道
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2018-09-14 23:03:21
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

AA10:=MA(C,10);
 BB10:=atan((aa10-ref(aa10,1)))*180/3.1416;
 STICKLINE(BB10>1 and AA10>ref(AA10,1), AA10,REF(AA10,1),8,0),colorred;
 STICKLINE(BB10<1 and AA10<ref(AA10,1), AA10,REF(AA10,1),8,1),COLORgreen;
 AA20:=MA(C,20);
 BB20:=atan((aa20-ref(aa20,1)))*180/3.1416;
 STICKLINE(BB20>1,AA20,REF(AA20,1),8,0),COLORYELLOW;
 STICKLINE(BB20<1,AA20,REF(AA20,1),8,1),COLORbbcccc;

//CZW-G
 input:p1(3,0,30),p2(6,1,300),p3(18,1,300),p4(250,0,300);
 Var1:=(C+L+H)/3;
 Var2:=eMA(Var1,6);
 Var3:=eMA(Var2,5);
 Var4:=eMA(Var3,12);
 Var5:=eMA(Var4,5);
生命线:eMA(Var3,30),COLORRED,POINTDOT;
 DRAWICON(C>=生命线,生命线,10);
 DRAWICON(C<生命线,生命线,11);
 a:=HHV(MA((L+H+C)/3,3),3);
 b:=llv(MA((L+H+C)/3,3),10);
 STICKLINE(BARSCOUNT(C)=SYSPARAM(1),a,a,20,0),Coloryellow,linethick3,shift1;
 DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),a,a,3),shift3,colorYELLOW;
 STICKLINE(BARSCOUNT(C)=SYSPARAM(1),b,b,20,0),ColorDB3FDD,linethick3,shift1;
 DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),b,b,3),shift3,ColorDB3FDD;
 DRAWTEXT(sysparam(2)=BARPOS,c,' '+BLKNAME),COLORccffcc,ALIGN4;//板块
a1:=cost(95);
 a2:=cost(5);
 ly:=(a1-a2)*100/(a1+a2);
 drawicon(ly>ref(ly,1), l*0.98,8)ALIGN5;
 input:N(3);
 A1:=REF(H,N)=HHV(H,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
 L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
 X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
 G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1),LINETHICK0;{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
 X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
 G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1),LINETHICK0;{过滤后高点}
 ///HD:="jgb.HD"(N);LD:="jgb.LD"(N);
 R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
★压力1:DRAWLINE(S2,H,S1,H,1),Color80FFFF;
 ★支撑1:DRAWLINE(U2,L,U1,L,1),POINTDOT,Color00FFFF,linethick2;
 ★压力2:DRAWLINE(S3,H,S2,H,1),ColorFF8000;
 ★支撑2:DRAWLINE(U3,L,U2,L,1),POINTDOT,ColorFF8000;
 ★压力3:DRAWLINE(S4,H,S3,H,1),Color0000FF;
 ★支撑3:DRAWLINE(U4,L,U3,L,1)POINTDOT,Color0000FF;
 DRAWICON(S2,H*1.01,10); DRAWICON(S3,H*1.01,10);
 DRAWNUMBER(S2,H*1.02,H,2),COLORMAGENTA;
 DRAWNUMBER(S1,H*1.02,H,2),COLORMAGENTA;
 DRAWNUMBER(S3,H*1.02,H,2),COLORMAGENTA;
 DRAWICON(U1,L*0.99,11); DRAWICON(U2,L*0.99,11);
 DRAWICON(U3,L*0.99,11);DRAWICON(U4,L*0.99,11);
 DRAWNUMBER(U1,L*0.98,L,2),COLORCYAN;
 DRAWNUMBER(U2,L*0.98,L,2),COLORCYAN;
 DRAWNUMBER(U3,L*0.98,L,2),COLORCYAN;
 DRAWNUMBER(U4,L*0.98,L,2),COLORCYAN;
 STICKLINE(open>=close ,close ,open,0,0 ),COLOR00FF00;
 STICKLINE(open>=close ,close ,open,8,0 ),COLOR008800;
 STICKLINE(open>=close ,close ,open,7,0 ),COLOR009900;
 STICKLINE(open>=close ,close ,open,6,0 ),COLOR00AA00;
 STICKLINE(open>=close ,close ,open,5,0 ),COLOR00BB00;
 STICKLINE(open>=close ,close ,open,4,0 ),COLOR00CC00;
 STICKLINE(open>=close ,close ,open,3,0 ),COLOR00DD00;
 STICKLINE(open>=close ,close ,open,2,0 ),COLOR00EE00;
 STICKLINE(open>=close ,close ,open,1,0 ),COLOR00FF00;
 STICKLINE(close>open,close,open,0,0) ,COLORFFBBFF;
 STICKLINE(close>open,close,open,8,0) ,COLORFF00FF;
 STICKLINE(close>open,close,open,7,0) ,COLORFF22FF;
 STICKLINE(close>open,close,open,6,0) ,COLORFF44FF;
 STICKLINE(close>open,close,open,5,0) ,COLORFF66FF;
 STICKLINE(close>open,close,open,4,0) ,COLORFF88FF;
 STICKLINE(close>open,close,open,3,0) ,COLORFF99FF;
 STICKLINE(close>open,close,open,2,0) ,COLORFFAAFF;
 STICKLINE(close>open,close,open,1,0) ,COLORFFBBFF;

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
官方千人交流微信群1:antu1688
官方千人交流微信群2:1500113880



关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭