股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  金字塔指标公式
股票配资开户注册领取2019元现金
玩牧客农场-注册就送50元
创丰1号策略(代码公开)[金字塔模型]
  • 相关简介: 测试已通过
  • 内容标签: 金字塔,模型
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2018-09-14 22:42:06
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

abb:=not(islastbar) or (islastbar and tholding2=0);

ma1:ma(c,5);

ma2:ma(c,10);

ma3:ma(c,20);

ma4:ma(c,60);


创丰1号-A:VALUEWHEN(TIME=0916,O),COLORMAGENTA;


DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);

DEA  := EMA(DIFF,9);

macd1 := 2*(DIFF-DEA), COLORSTICK;


VARIABLE: aspect=0;

VARIABLE: stopprice=0;

VARIABLE: stopnum = 1.6;


RUNMODE:0;  


if barpos = 0 then

 stopprice := l - stopnum;


if aspect = 0 then

begin


if l <= stopprice then

begin


 aspect:= 1;

 stopprice := h+stopnum;

end



if l - stopnum > stopprice then

 stopprice := l-stopnum;

end


if aspect = 1 then

begin


if h >= stopprice then

begin


 aspect:= 0;

 stopprice := l-stopnum;

end



if h + stopnum < stopprice then

 stopprice := h+stopnum;

end



RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;


手数:=1;

a1:=k>ref(k,1) and c-ENTERPRICE>=9 ;

a2:=k<ref(k,1) and c-ENTERPRICE<=-9 ;



EMA13:=EMA(C,10),COLORWHITE;

EMA21:=EMA(C,21),COLORYELLOW;

EMA34:=EMA(C,34),COLORFF00FF;

EMA60:=MA(C,55),COLORFFCC66;

X1:=(C+L+H)/3;

X2:=EMA(X1,5);

X3:=EMA(X2,4);


STICKLINE(C>stopprice,LOW,HIGH,0.1,1),COLORRED;

STICKLINE(C>stopprice,CLOSE,OPEN,3,1),COLORRED;

STICKLINE(C<stopprice,LOW,HIGH,0.1,1),COLORFFFF52;

STICKLINE(C<stopprice,CLOSE,OPEN,3,0),COLORFFFF52;




BUY1:=(K>REF(K,1)&&D<REF(D,1)&&J>REF(J,1))&&C>stopprice&&time>0915&&time<=1510 and macd1>ref(macd1,1) and  holding<=0 ;

SELL1:=(J<REF(J,1)&&K<REF(K,1)&&D>REF(D,1))&&C<stopprice&&time>0915&&time<=1510 and  macd1<ref(macd1,1) and holding>=0 ;


VARIABLE:DUOKONG=0;

TSFS:=0;

ORDVOL:=1;     {开仓手数}

ZSDS:=8;    


VARIABLE:YDZY=1;

VARIABLE:HIGHPRICE=0,LOWPRICE=0;

VARIABLE:DHCDS=5,KHCDS=5;

VARIABLE:DYLDS=1,KYLDS=1;

VARIABLE:Z3B1:=1;

DUOKONG:=1;


IF HOLDING<0 THEN BEGIN

IF BUY1 THEN BEGIN  

 空平:SELLSHORT(1,ORDVOL,THISCLOSE),ORDERQUEUE;

END



IF  a1 THEN BEGIN

 空损:SELLSHORT(1,ORDVOL,THISCLOSE),ORDERQUEUE;

  多1开:BUY(1=1,ORDVOL,THISCLOSE),ORDERQUEUE;

END



IF YDZY=1 THEN BEGIN


 IF L<LOWPRICE THEN BEGIN

  LOWPRICE:=L;

 END



 IF ENTERPRICE-LOWPRICE>=KYLDS and c-ENTERPRICE<=-0.2 THEN BEGIN

  IF L-LOWPRICE>=KHCDS THEN BEGIN

   空赢:SELLSHORT(1,ORDVOL,THISCLOSE),ORDERQUEUE;

  END

 END

END  www.stock87.com



IF Z3B1=1 THEN BEGIN

 IF ENTERPRICE-LOWPRICE>=3 THEN BEGIN

  IF ENTERPRICE-L<=1.2 THEN BEGIN


  END

 END

END

END


IF HOLDING=0 THEN BEGIN

IF DUOKONG=1 OR DUOKONG=2 THEN BEGIN

 IF BUY1  and abb  THEN BEGIN

  多开:BUY(1=1,ORDVOL,THISCLOSE),ORDERQUEUE;

  HIGHPRICE:=ENTERPRICE;

 END

END

END


IF HOLDING>0 THEN BEGIN

IF SELL1 THEN BEGIN

 多平:SELL(1,ORDVOL,THISCLOSE),ORDERQUEUE;;

END



IF a2 THEN BEGIN

 多损:SELL(1,ORDVOL,THISCLOSE),ORDERQUEUE;

    空1开:BUYSHORT(1=1,ORDVOL,THISCLOSE),ORDERQUEUE;

END


IF YDZY=1 THEN BEGIN


 IF H>HIGHPRICE THEN BEGIN

  HIGHPRICE:=H;

 END



 IF HIGHPRICE-ENTERPRICE>=DYLDS and c-ENTERPRICE>=0.2 THEN BEGIN

  IF HIGHPRICE-H>=DHCDS THEN BEGIN

   多赢:SELL(1,ORDVOL,THISCLOSE),ORDERQUEUE;

  END

 END

END


IF Z3B1=1 THEN BEGIN

 IF HIGHPRICE-ENTERPRICE>=3 THEN BEGIN

  IF H-ENTERPRICE<=1.2 THEN BEGIN


  END

 END

END

END

IF HOLDING=0 THEN BEGIN

IF DUOKONG=1 OR DUOKONG=3 THEN BEGIN

 IF SELL1  and abb  THEN BEGIN

  空开:BUYSHORT(1=1,ORDVOL,THISCLOSE),ORDERQUEUE;

  LOWPRICE:=ENTERPRICE;

 END

END

END



 IF time>=1513 THEN BEGIN

 收盘平空:SELLSHORT(1,ORDVOL,THISCLOSE),ORDERQUEUE;

 END


 IF time>=1513 THEN BEGIN

 收盘平多:SELL(1,ORDVOL,THISCLOSE),ORDERQUEUE;

 END

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)

官方千人交流微信群1:rafczx

官方千人交流QQ群8:1500113880




关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭