股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  金字塔指标公式
股票配资开户注册领取2019元现金
玩牧客农场-注册就送50元
日线非引用周线kdj算法(金字塔软件源码贴图)
  • 相关简介: 测试已通过
  • 内容标签: 金字塔,软件
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2018-09-14 22:40:37
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

首先建立一个指标作为引用对象
命名为:YY1
代码如下:
n:=9;
RSV:(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;
ll:llv(l,n-1);
hh:hhv(h,n-1);

然后另外建立一个指标,用来实际获取周线的kdj:
命名随意,代码如下:
rsv1:=stkindi('','yy1.rsv',0,7,-1);
k1:=stkindi('','yy1.k',0,7,-1);
d1:=stkindi('','yy1.d',0,7,-1);
c1:=callstock(stklabel,vtclose,7,-1),linethick0;
cc:=ref(c,1)=c1,linethick0;
nn:=barslast(cc),linethick0;
hh:=stkindi('','yy1.hh',0,7,-1);
ll:=stkindi('','yy1.ll',0,7,-1);
mn:=min(ll,llv(l,nn+1));
mx:=max(hh,hhv(h,nn+1));
rsv:=(callstock(stklabel,vtclose,6)-mn)/(mx-mn)*100;
k:(rsv+2*k1)/3;
d:(k+2*d1)/3;
j:3*k-2*d;

从图里面就可以看到,作为对比的第一个幅图上的kdj引用周线数值,是一个礼拜就一个数值,反映不了每天的变化情况;而第二个幅图上的就是流线型的,每天都有数值,可以看到每天的kdj周线数值是如何变化的。

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)

官方千人交流微信群1:rafczx

官方千人交流QQ群8:1500113880




关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭