股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  文华指标公式
股票配资开户注册领取2019元现金
牧客农场-注册送50金币
文华 股指日内1分钟限价止损和追踪止盈模型
  • 相关简介: 测试已通过
  • 内容标签: 操盘手公式网,股票公式,选股公式,独家内参,早盘必读,热点概念,炒股学习,股票软
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2018-09-14 22:36:47
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

具体源码如下:

//参数:15,2,2,6,10
JJ:=(2*C+H+L)/4;
AA:=EMA(JJ,N1);
BB:=REF(AA,1);
MA1:=MA(C,20);
MA2:=MA(C,55);

TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=REF(MA(TR,20),1);

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);

//定义限价止损变量
MINPRICE('IF1207')
A:=0.2;//取合约最小变动价位
HH:=HHV(H,BARSBK+1);//买开仓位置到现在最高价
LL:=LLV(L,BARSSK+1);//卖开仓位置到现在最低价

//限价止损模块:
SL:=N2*ATR;
TP:=N3*SL;
DTP:=(N4/10)*SL;

A1:=BKPRICE+TP;
A2:=A1+DTP;
A3:=A1-N5*A;
A4:=HH-DTP;//以上为根据止赢点差计算多单追踪止赢位置
B1:=SKPRICE-TP;
B2:=B1-DTP;
B3:=B1+N5*A;
B4:=LL+DTP;//以上为根据止赢点差计算空单追踪止赢位置

CROSS(AA,BB)&&MA1>MA2&&TIME>0920&&TIME<1455,BK;
TIME>=1510||(((C<=BKPRICE-SL)||(HH>=A1&&HH<=A2&&C<=A3)||(HH>A2&&C<=A4))&&BKPRICE>0),SP ;

CROSS(BB,AA)&&MA1<MA2&&TIME>0920&&TIME<1455,SK;
TIME>=1510||(((C>=SKPRICE+SL)||(LL<=B1&&LL>=B2&&C>=B3)||(LL<B2&&C>=B4))&&SKPRICE>0),BP;
AUTOFILTER;

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
官方千人交流微信群1:antu1688
官方千人交流微信群2:1500113880



关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭