股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  通达信公式
股票配资开户注册领取2019元现金
牧客农场-注册送50金币
MACD双背离(源码副图贴图)
  • 相关简介: 测试已通过
  • 内容标签:
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2018-01-09 08:39:17
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)


macd双背离

DIFF: EMA(CLOSE,12) - EMA(CLOSE,26);
DEA: EMA(DIFF,9);
MACD: 2*(DIFF-DEA),COLORSTICK;
JC:=DEA-DIFF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIFF,DEA)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积)
AND 本次最低价<前次最低价 ),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
底背驰:= IF (CROSS(DIFF,DEA),REF(Y1,1),0);
DRAWTEXT(底背驰,-0.01,'积底'),COLORRED;
{DRAWBAND(DIFF,RGB(200,50,55),DEA,RGB(50,100,10));}
X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIFF)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
顶背驰:= IF (CROSS(DEA,DIFF),REF(Y2,1),0);
DRAWTEXT(顶背驰,0.01,'积顶'),COLORGREEN;
A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,DEA,' 线底'),COLORRED;
A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,DEA,'线顶'),COLORGREEN;

A1:=DIFF<0 AND DEA<0;
A2:=A1>REF(A1,1);
A3:=BARSLAST(A2);


下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
官方千人交流微信群1:antu1688
官方千人交流微信群2:1500113880



关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

操盘手公式网   Copyright © 2010-2018   stock87.com™, All Rights Reserved.  浙ICP备17017803号
   免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
    本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


浙ICP备17017803号
微信公众号 回顶部
关闭
关闭
关闭
关闭