今日股市上证指数大盘股票行情及汇率牌价查询由操盘手公式网为您更新 大盘 上证
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 今日股市行情 今日大盘 上证指数 指标 股票 macd boll kdj obv cci rsi dmi sar vol ddx ddy
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 美元兑人民币 外汇 期货 基金 操盘手 股吧
当前位置:首页 >> 指标公式 >>  大智慧指标公式
大智慧最全最厉害的指标功能主图源码
  • 相关简介: 今日股市
  • 内容标签: 大智慧
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2020-04-07 16:55:33
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

R1:=MA(CLOSE,1);
R2:=MA(CLOSE,3);
R3:=(MA(R2,1)*1);
R4:=(MA(R2,3)*1);
X1:=(C+L+H)/3;
DD:=FINANCE2(35);
SS:=FINANCE2(37);
GG:=FINANCE2(3);
TH:=DYNAINFO(39);
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
a1:=IF((CLOSE < 800),((AMOUNT / vol) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));
a2:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;
a3:=EMA((MA(a1,5)),10);
a4:=EMA((MA(a1,15)),10);
a5:=EMA((MA(a1,13)),21);
a6:=((a3 + a4) + a5) / 3;
决策线:EMA((MA(CLOSE,5)),3),linethick2,colorFF0000;
PARTLINE(决策线,决策线 > (REF(决策线,3)),RGB(255,0,0)),linethick2,Color3300FF;
DRAWTEXT(((CLOSE > 0) AND (DISPSTATUS = 2)),(决策线 * 0.95),'决策价:'+决策线),MOVE10,ALIGN2,linethick2,colorRed;
{支撑}
VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力: REF(HIGH,BARSLAST(Var2222)), POINTDOT,ColorEA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(Var2222)),REF(HIGH,BARSLAST(Var2222)),5,0),LINETHICK3,ColorEA91B5;
支撑: REF(LOW,BARSLAST(Var4444)), POINTDOT,Color00b4ff,linethick3;
STICKLINE(CLOSE,REF(LOW,BARSLAST(Var4444)),REF(LOW,BARSLAST(Var4444)),5,0),LINETHICK3,Color00b4ff;
弱势双线持币:HHV(MA(HIGH,(3)),2),LINETHICK2,COLOR00FF00;
强势单线持股:LLV(MA(HIGH,(3)),1),LINETHICK2,ColorFF00FF;
{老鼠仓}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:BB1 AND CC1 AND DD1 AND EE1,linethick0;
DRAWTEXT(老鼠仓, (LOW* 0.99),'老鼠仓'),LINETHICK3,Color40CCFF;
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(20,100,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(32,100,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(32,100,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘走势良好,量能理想,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(32,100,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(32,100,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
{买入卖出}
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,LOW*1,'←买'),CROSSDOT,LINETHICK3,COLORRED;
DRAWTEXT(卖1>0,HIGH*1,'←卖'),CROSSDOT,LINETHICK3,COLORGREEN;
{黑码线}
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑码线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趋势线,0)AND 黑码线<40,(HIGH* 0.97),'▲大黑码'),LINETHICK3,COLORYELLOW;
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
压力Ⅰ:= 2*重心-LOW;
压力Ⅱ:= 重心 + PT;
支撑Ⅰ:= 2*重心-HIGH;
支撑Ⅱ:= 重心 - PT;
DRAWTEXTABS(100,13,' 《逆势操作》'),ColorFFFFFF;
DRAWTEXTABS(175,13,' 重心:'+重心),Coloryellow;
DRAWTEXTABS(100,32,' 支 撑'),ColorFFFFFF;
DRAWTEXTABS(100,49,' '+支撑Ⅰ),ColorFFFFFF;
DRAWTEXTABS(100,67,' '+支撑Ⅱ),ColorFFFFFF;
DRAWTEXTABS(100,32,' 压 力'),ColorFFFFFF;
DRAWTEXTABS(100,49,' '+压力Ⅰ),ColorFFFFFF;
DRAWTEXTABS(100,67,' '+压力Ⅱ),ColorFFFFFF;
DRAWTEXTABS(100,10,'│'),Color00FFFF;
DRAWTEXTABS(100,22,'│'),Color00FFFF;
DRAWTEXTABS(100,34,'│'),Color00FFFF;
DRAWTEXTABS(100,46,'│'),Color00FFFF;
DRAWTEXTABS(100,58,'│'),Color00FFFF;
DRAWTEXTABS(100,70,'│'),Color00FFFF;
DRAWTEXTABS(243,10,'│'),Color00FFFF;
DRAWTEXTABS(243,22,'│'),Color00FFFF;
DRAWTEXTABS(243,34,'│'),Color00FFFF;
DRAWTEXTABS(243,46,'│'),Color00FFFF;
DRAWTEXTABS(243,58,'│'),Color00FFFF;
DRAWTEXTABS(243,70,'│'),Color00FFFF;
DRAWTEXTABS(171,30,'│'),Color00FFFF;
DRAWTEXTABS(171,34,'│'),Color00FFFF;
DRAWTEXTABS(171,46,'│'),Color00FFFF;
DRAWTEXTABS(171,58,'│'),Color00FFFF;
DRAWTEXTABS(171,70,'│'),Color00FFFF;
DRAWTEXTABS(105,5,'────────────'),Color00FFFF;
DRAWTEXTABS(105,25,'────────────'),Color00FFFF;
DRAWTEXTABS(105,42,'────────────'),Color00FFFF;
DRAWTEXTABS(105,59,'────────────'),Color00FFFF;
DRAWTEXTABS(105,76,'────────────'),Color00FFFF;
{以下大笔出货标识}
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR20:=(HIGH+LOW+CLOSE)/3;
VAR21:=(VAR20-MA(VAR20,14))/(0.015*AVEDEV(VAR20,14));
VAR22:=(VAR20-MA(VAR20,70))/(0.015*AVEDEV(VAR20,70));
VAR23:=IF(VAR21>=150 AND VAR21<200 AND VAR22>=150 AND VAR22<200,10,0);
VAR24:=IF(VAR21<=-150 AND VAR21>-200 AND VAR22<=-150 AND VAR22>-200,-10,VAR23);
VAR25:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR26:=100-ABS(VAR25);
VAR27:=IF(VAR26<90,VAR26,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR22>=200 AND VAR21>=150,15,IF(VAR22<=-200 AND VAR21<=-150,-15,VAR24))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR27<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,'大笔出货'),LINETHICK3,COLORFFCC66;
AB1:=COST(0.33);
AB2:=COST(5);
AB3:=COST(15);
AB4:=COST(55);
AB5:=COST(97);
获利:=WINNER(CLOSE)*100;
套牢:=100-WINNER(CLOSE)*100;
DRAWTEXTABS(520,25,'建仓:'+NUMTOSTRN(AB2,2)),COLOR00FFFF;
DRAWTEXTABS(600,25,'快刀:'+NUMTOSTRN(AB3,2)),COLOR00FFFF;
DRAWTEXTABS(675,25,'升浪:'+NUMTOSTRN(AB4,2)),COLOR00FFFF;
DRAWTEXTABS(520,40,'获利:'+NUMTOSTRN(获利,2)+'%'),COLOR00FFFF;
DRAWTEXTABS(600,40,'套牢:'+NUMTOSTRN(套牢,2)+'%'),COLOR00FFFF;
DRAWTEXTABS(675,40,'预测:'+NUMTOSTRN(AB5,2)),COLOR00FFFF;
{量能饱和度}
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXTREL(350,40,'量能饱和度:'+NUMTOSTRN(SAT,0)),LINETHICK4,ColorFF00FF;
DRAWTEXTREL(0,0,'总股本:'+NUMTOSTRN(FINANCE2(35),0)+'流通A股:'+NUMTOSTRN(FINANCE2(37),0)+'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+'每股公积金:'+NUMTOSTRN(FINANCE2(7),2)+'元'+'昨:'+NUMTOSTRN(DYNAINFO(3),2)+'开:'+NUMTOSTRN(DYNAINFO(4),2)+'高:'+NUMTOSTRN(DYNAINFO(5),2)+'低:'+NUMTOSTRN(DYNAINFO(6),2)+'收:'+NUMTOSTRN(DYNAINFO(7),2)+'涨幅:'+NUMTOSTRN((DYNAINFO(14)*100),2)+'%'+'振幅:'+NUMTOSTRN((DYNAINFO(13)*100),2)+'%'+'换手率:'+NUMTOSTRN((DYNAINFO(37)*100),2)+'%'),linethick2,colorwhite;
aa:=(ref(close,1)+ref(close,2)+open)/3;
DRAWTEXTABS(320,50,'今日保护价:'+NUMTOSTRN(aa,2)),LINETHICK4,COLOR00FFFF;
DRAWGBK(c,'');
{金印组合}
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.03 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,L,'←金印'),linethick3,coloryellow;
{以下定义坚决买进}
var77:=ema(amount/vol/100,3);
var88:=ema(var77,88);
var99:=ema(var77,88)*0.85;
varah:=var99*0.87;
varbh:=low<varah and close>ref(close,1)*1.02;
drawtext(filter(varbh,6),l-0.08,'←坚决买进'),linethick3,colorff00ff;
{以下设置强势狙击}
BB05:=atan(((MA(C,5))/ref((MA(C,5)),1)-1)*100)*180/3.1416;
BB10:=atan(((MA(C,10))/ref((MA(C,10)),1)-1)*100)*180/3.1416;
BB30:=atan(((MA(C,30))/ref((MA(C,30)),1)-1)*100)*180/3.1416;
强势狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
drawtext(强势狙击,LOW*0.98,'←强势狙击'),linethick3,colorwhite;
{以下定义资金进场}
VAR3e:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR4e:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR5e:=VAR3e>REF(VAR4e,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR5e AND COUNT(VAR5e,30)=1,low,'←资金进场'),linethick3,COLORYELLOW;
{以下定义顶底背离}
LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'←底背离'),linethick3,COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'←顶背离'),linethick3,COLOR1880FF;
{操盘手BS}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(bu,LOW,'B'),ALIGN1,VALIGN0,colorYELLOW,linethick4;
drawtext(sel,HIGH,'S'),ALIGN1,VALIGN2,colorFFFF00,linethick4;


版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
关闭
关闭
关闭
关闭
关闭
关闭