今日股市上证指数大盘股票行情及汇率牌价查询由操盘手公式网为您更新 大盘 上证
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 今日股市行情 今日大盘 上证指数 指标 股票 macd boll kdj obv cci rsi dmi sar vol ddx ddy
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 美元兑人民币 外汇 期货 基金 操盘手 股吧
当前位置:首页 >> 指标公式 >>  飞狐指标公式
把新暴涨主图这两个通达信的公式改成飞狐的
  • 相关简介: 今日股市
  • 内容标签: 通达信公式,改成飞狐
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2018-12-03 08:23:44
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

编写要求:

请老师帮助把下面这两个通达信的公式改成飞狐的,谢谢老师! 一、新暴涨主图 公式名称:新暴涨主图 公式描述:暴涨主图与操盘专用均线合并 参数 最小 最大 缺省 M1 2 1000 5 M2 2 1000 10 M3 2 1000 20 M4 2 1000 30 M5 2 1000 60 MA1:MA(CLOSE,M1); MA2:MA(CLOSE,M2); MA3:MA(CLOSE,M3); MA4:MA(CLOSE,M4); MA5:MA(CLOSE,M5); 涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0); STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED; STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED; DRAWTEXT(涨停,L-0.1,'涨停'),COLORRED; C3:=REF(C,1); 跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0); STICKLINE(跌停,OPEN,CLOSE,4,0),COLORBLUE; STICKLINE(跌停,OPEN,CLOSE,3,0),COLORBLUE; DRAWTEXT(跌停,H+0.3,'跌停'),COLORBLUE; 净资产:FINANCE(34),NODRAW,COLORFF00FF; 每股收益:FINANCE(33),NODRAW,COLORFF7F50; 市盈率:DYNAINFO(39),NODRAW,COLORFF00FF; 流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED; MA10:MA(C,10),COLOR00FFFF,LINETHICK2; DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26); DEA:=EMA(DIF,9); AAA:=(DIF-DEA)*2*60; 起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2; DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK2; 二、暴涨选股 公式名称:暴涨选股 公式描述:盘中预警 DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26); DEA:=EMA(DIF,9); AAA:=(DIF-DEA)*2*60; 起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2; XG:EXIST(起爆,1); 第二个预警公式我不知道周期应该是1分钟、5分钟、还是日线好?请老师修改后告知在飞狐预警使用的是哪一个周期。谢谢!

股旁网解答:

{新暴涨主图}

{DCLOSE是未来函数}
INPUT:M1(5,2,1000),M2(10,2,1000),M3(20,2,1000),M4(30,2,1000),M5(60,2,1000);
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,8,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,7,0),COLORRED;
DRAWTEXT(涨停,L-0.1,'涨停'),COLORRED;
C3:=REF(C,1);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,8,0),COLORBLUE;
STICKLINE(跌停,OPEN,CLOSE,7,0),COLORBLUE;
DRAWTEXT(跌停,H+0.3,'跌停'),COLORBLUE;
净资产:FINANCE(34),LINETHICK0,COLORFF00FF;
每股收益:FINANCE(33),LINETHICK0,COLORFF7F50;
市盈率:DYNAINFO(39),LINETHICK0,COLORFF00FF;
流通市值:(FINANCE(42)/100000000),LINETHICK0,COLORRED;
MA10:MA(C,10),COLOR00FFFF,LINETHICK2;
TH:=BARSLAST(C<REF(C,1));
TL:=BARSLAST(C>REF(C,1));
HC:=SETVAL(C>REF(C,1) OR C=REF(C,1) AND REF(C,1)>REF(C,2),C,-TH,C);
LC:=SETVAL(C<REF(C,1) OR C=REF(C,1) AND REF(C,1)<REF(C,2),C,-TL,C);
DCLOSE:=IF(C>REF(C,1) OR C=REF(C,1) AND REF(C,1)>REF(C,2),HC,IF(C<REF(C,1) OR C=REF(C,1) AND REF(C,1)<REF(C,2),LC,C));
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK2;
{暴涨选股}
{DCLOSE是未来函数}
TH:=BARSLAST(C<REF(C,1));
TL:=BARSLAST(C>REF(C,1));
HC:=SETVAL(C>REF(C,1) OR C=REF(C,1) AND REF(C,1)>REF(C,2),C,-TH,C);
LC:=SETVAL(C<REF(C,1) OR C=REF(C,1) AND REF(C,1)<REF(C,2),C,-TL,C);
DCLOSE:=IF(C>REF(C,1) OR C=REF(C,1) AND REF(C,1)>REF(C,2),HC,IF(C<REF(C,1) OR C=REF(C,1) AND REF(C,1)<REF(C,2),LC,C));
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;

XG:ANY(起爆,1);


版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

人民币汇率 股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx



热门文章Top

股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

Copyright © 2020 操盘手公式网 (www.stock87.com) , All Rights Reserved. 广告合作QQ: 69948046

为股民提供大盘,上证指数,指标公式,选股公式,股票公式,股票,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网


浙ICP备17017803号-1
关闭
关闭
关闭
关闭
关闭
关闭