选股公式 股市行情 抄底公式
股票软件 通达信 大智慧 同花顺 飞狐软件 东财通 操盘手 指南针 钱龙 股票软件 手机炒股 股票开户 证券之星 金融界 分析家 股票入门 外汇 期货 基金 炒股技巧
股票公式 通达信 大智慧 同花顺 飞狐公式 选股宝 股票池 通达信| 大智慧| 股票书籍 炒股指标 macd boll kdj obv cci rsi dmi sar vol ddx ddy wr ddz cr roe
当前位置:首页 >> 股票公式 >>  vol
股民学校
私募操盘手内部培训视频
史上最全的综合成交量指标源码 17 个系列
  • 相关简介: 股票入门基础知识
  • 内容标签: 成交量指标公式
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2019-11-21 23:10:00
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 指标公式
软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

1.双向成交量

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:=VOL,POINTDOT;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH- OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLOR00FF00,POINTDOT;
地量:=VOL<LLV(VOL,14)*1.001;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(VOL>0,VOL,0,3,1),COLORWHITE;
STICKLINE(主动买盘>V/2,0,V,2,0),COLORYELLOW;
STICKLINE(主动买盘<=V/2,0,V,2,0),COLORLIGRAY;
STICKLINE(主动买盘>0,0,主动买盘,2,0),COLORRED;
STICKLINE(主动卖盘<0,0,主动卖盘,2,0),COLOR00FF00;
STICKLINE(地量>0,0,VOL,1,0),COLORMAGENTA;
STICKLINE(V2>=1,V,0,1,0),COLORYELLOW;



2.量价线,:几乎量价线任何一次上穿黑马线都是买入时机    

LS3:=LLV(HIGH,240);
LS4:=100*(CLOSE-LS3)/LS3;
LS5:=REF(LLV(CLOSE,480),1);
LS6:=REF(HHV(CLOSE,480),1);
LS7:=100*(CLOSE-LS5)/(LS6-LS5);LS8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
LS9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
LSA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
LSB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
LSC1:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
LSC:=LSC1/4;
LSD:=IF(LSC>23.6,LSC,0);
LSE:=LSC<1;
LSF:=LSD;
LS10:=LS4<LS7 AND LS4<0;
LS11:=1;
LS12:=(HIGH+LOW+CLOSE*2)/4*LS11;
LS13:=EMA(LS12,21);
LS14:=STD(LS12,21);
LS15:=((LS12-LS13)/LS14*100+200)/4*LS11;
LS161:=EMA(LS15,89);
LS16:=(LS161-25)*1.56*LS11;
LS171:=EMA(LS16,5);
LS17:=LS171*1.22*LS11;
LS181:=EMA(LS17,3);
LS18:=LS181*LS11;
LS19:=3*LS17-2*LS18*LS11;
LS1A:=IF(CROSS(LS19,LS17)AND CROSS(LS19,LS18)AND CROSS(LS17,LS18),1,0);
LS1B:=IF(CROSS(LS17,LS19)AND CROSS(LS18,LS19)AND CROSS(LS18,LS17),1,0);
LS1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
LS1D1:=EMA(CLOSE,2);
LS1D2:=EMA(CLOSE,89);
LS1D:=LS1D1-LS1D2;
LS1E:=EMA(LS1D,30);
LS1F:=(LS1D-LS1E)*20;
LS20:=POW(LS1F,3)*0.1+POW(LS1F,2);
LS21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
LS22:=EMA(LS21*0.97,3);
LS23:=(HIGH+LOW+CLOSE)/3;
LS24:=(LS23-MA(LS23,14))/(0.015*AVEDEV(LS23,14));
LS25:=IF(LS1F>0.015,LS20,0)/45;
庄拉线:=LS25;
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
LS2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
LS2B:=EMA(LS2A*0.97,3);
LS2C:=(HIGH+LOW+CLOSE)/3;
LS2D:=(LS2C-MA(LS2C,14))/(0.015*AVEDEV(LS2C,14));
黑马线:IF(LS28>0.1,LS29,0)*5,LINETHICK2;
量价线:(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100,LINETHICK2;
常数线:=0;
X1:LS3;
X2:LS5;
X3:LS6;
偏移:XMA(H,10);观察:MA(H,10);
DRAWICON(LONGCROSS(偏移,观察,1),L*0.9975,1) ;
DRAWICON(LONGCROSS(观察,偏移,1),H*1.0025,2) ;





3.资金监测双向成交量

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0;

主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;

STICKLINE(C<O ,0,VOL,3.2,0),COLORFF1100;

STICKLINE(C<O ,0,VOL,2.7,0),COLORFF3300;

STICKLINE(C<O ,0,VOL,2.1,0),COLORFF5500;

STICKLINE(C<O ,0,VOL,1.5,0),COLORFF7700;

STICKLINE(C<O ,0,VOL,0.9,0),COLORFF9900;

STICKLINE(C<O ,0,VOL,0.3,0),COLORFFBB00;

STICKLINE(C=O AND C<REF(C,1),0,VOL,3.2,0),COLOR006000;

STICKLINE(C=O AND C<REF(C,1),0,VOL,2.7,0),COLOR007500;

STICKLINE(C=O AND C<REF(C,1),0,VOL,2.1,0),COLOR009100;

STICKLINE(C=O AND C<REF(C,1),0,VOL,1.5,0),COLOR00A600;

STICKLINE(C=O AND C<REF(C,1),0,VOL,0.9,0),COLOR00BB00;

STICKLINE(C=O AND C<REF(C,1),0,VOL,0.3,0),COLOR00CC00;

STICKLINE(C=O AND C>REF(C,1),0,VOL,3.2,0),COLOR555555;

STICKLINE(C=O AND C>REF(C,1),0,VOL,2.7,0),COLOR777777;

STICKLINE(C=O AND C>REF(C,1),0,VOL,2.1,0),COLOR999999;

STICKLINE(C=O AND C>REF(C,1),0,VOL,1.5,0),COLORBBBBBB;

STICKLINE(C=O AND C>REF(C,1),0,VOL,0.9,0),COLORDDDDDD;

STICKLINE(C=O AND C>REF(C,1),0,VOL,0.3,0),COLORFFFFFF;

STICKLINE(C>O,0,VOL,3.2,0),COLORFF11FF;

STICKLINE(C>O,0,VOL,2.7,0),COLORFF33FF;

STICKLINE(C>O,0,VOL,2.1,0),COLORFF55FF;

STICKLINE(C>O,0,VOL,1.5,0),COLORFF77FF;

STICKLINE(C>O,0,VOL,0.9,0),COLORFF99FF;

STICKLINE(C>O,0,VOL,0.3,0),COLORFFBBFF;

资金异动:VOL/MA(VOL,55)*100,COLORYELLOW;

{}

STICKLINE(主动买盘>0,0,主动买盘,3.2,0),COLOR000055;

STICKLINE(主动买盘>0,0,主动买盘,2.7,0),COLOR000077;

STICKLINE(主动买盘>0,0,主动买盘,2.1,0),COLOR000099;

STICKLINE(主动买盘>0,0,主动买盘,1.5,0),COLOR0000BB;

STICKLINE(主动买盘>0,0,主动买盘,0.9,0),COLOR0000DD;

STICKLINE(主动买盘>0,0,主动买盘,0.3,0),COLOR0000FF;

STICKLINE(主动卖盘<0,0,主动卖盘,3.2,0),COLOR006000;

STICKLINE(主动卖盘<0,0,主动卖盘,2.7,0),COLOR007500;

STICKLINE(主动卖盘<0,0,主动卖盘,2.1,0),COLOR009100;

STICKLINE(主动卖盘<0,0,主动卖盘,1.5,0),COLOR00A600;

STICKLINE(主动卖盘<0,0,主动卖盘,0.9,0),COLOR00BB00;

STICKLINE(主动卖盘<0,0,主动卖盘,0.3,0),COLOR00CC00;

STICKLINE(资金异动>100 ,0,VOL,0.6,0),COLORYELLOW;

SQX:=(C-MA(CLOSE,13))*100;

DIFF:EMA(MA(SQX,7),1),COLOR00FFFF;

DEA:EMA(DIFF,7),COLOR00FF00;



4.破解DDX(预警)幅图

N:=20;

JJ:=(HIGH+LOW+CLOSE)/3;

QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));

QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));

QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));

QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));

DDX:((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),COLOR00AAAA,LINETHICK;

DX:=MA(DDX,5)*N;

STICKLINE(DDX>0,0,DDX,3,0),COLOR000088;

STICKLINE(DDX>0,0,DDX,2.5,0),COLOR0000AA;

STICKLINE(DDX>0,0,DDX,1.5,0),COLOR0000CC;

STICKLINE(DDX>0,0,DDX,1,0),COLOR0000EE;

STICKLINE(DDX<0,0,DDX,3,0),COLOR008800;

STICKLINE(DDX<0,0,DDX,2.5,0),COLOR00AA00;

STICKLINE(DDX<0,0,DDX,1.5,0),COLOR00CC00;

STICKLINE(DDX<0,0,DDX,1,0),COLOR00EE00;

DDX1:SMA(DX,3,1),COLORFFFFFF;

DDX2:SMA(DDX1,3,1),COLOR00FFFF;

DDX3:EMA(DDX2,5),COLORFF00FF;


预警:DDX>0 AND MA(V,5)>MA(MA(V,5),5) AND CROSS(DDX1,DDX2),LINETHICK;

天:=COUNT(DDX>0,5),COLORRED;

DRAWTEXT(预警,DDX*1.06,'★'),LINETHICK3,COLOR00FFFF;




5.资金流向

AA:=1;
BB:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
CC:=IF(((((AMOUNT / CLOSE) / (HHV(AMOUNT,9) / HHV(CLOSE,9))) * 100) > 100),100,(((AMOUNT / CLOSE) / (HHV(AMOUNT,9) / HHV(CLOSE,9))) * 100));
DD:=(BB / CC);
价异动排序:IF(AA,(DD / REF(DD,1)),0),STICK,COLOR0000FF;
EE:=(CC / BB);
量异动排序:IF(AA,(EE / REF(EE,1)),0),STICK,COLORFFFF00;
AAA:=((XMA(CLOSE,5) - REF(XMA(CLOSE,5),1)) / REF(XMA(CLOSE,5),1));
BBB:=((XMA(INDEXC,5) - REF(XMA(INDEXC,5),1)) / REF(XMA(INDEXC,5),1));
CCC:=REF(HHV(CLOSE,120),1);
DDD:=REF(LLV(CLOSE,120),1);
WW:=((100 * (CLOSE - DDD)) / (CCC - DDD));
今日资金流:(AMOUNT/100000000);
五日资金流:(EMA(今日资金流,5)/REF(EMA(今日资金流,5),5));
庄股:=((((((五日资金流 >= 2) AND (AAA > BBB)) AND (WW < 35)) AND AA) AND (BARSCOUNT(CLOSE) > 30)) OR (((((五日资金流 >= 2) AND (AAA > BBB)) AND (WW < 100)) AND AA) AND (BARSCOUNT(CLOSE) < 50)));
庄家显形:IF(庄股,888,0),LINETHICK1,COLORFF00FF;
A01:=DYNAINFO(7);
A02:=MA(AMOUNT / VOL /   100.000,VOL / CAPITAL);
A03:=BARSCOUNT(CLOSE);
A04:=SMA(CLOSE / HHV(HIGH, 120.000), 3.000, 1.000) *   100.000;
A05:=IF((A03 >   20.000),A04,0);
A06:=IF(((LOW > A01)),0,IF(((HIGH < A01)), 1.000,((A01 - LOW) +   0.009) / ((HIGH - LOW) +   0.009)));
A07:=DMA(A06,VOL / CAPITAL) *   100.000;
A08:=IF((A02 > A01),( 100.000 - A07),A07);
A09:IF(((((A07 > 0) AND (A07 > REF(A07, 1.000)))) AND (A05 <=   88.000)),A07,0),COLORYELLOW,LINETHICK1;
STICKLINE(A09 > 0,0,A09,0,0),COLORMAGENTA;




6.成交连(当时打错字了,公式类型:成交量型)
IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;
TX80:80,POINTDOT COLORYELLOW;
DX20:20,POINTDOT COLORGREEN;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,6),COLORRED;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORGREEN;
VAR3:=LLV(LOW,55); VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2; VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5); VAR9:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
DRAWICON(LONGCROSS(D,K,0.1),D,2),COLORRED;
DRAWICON(LONGCROSS(K,D,0.1),K,1),COLORGREEN;


7通达信主力持仓均线公式

换手:=V*100/CAPITAL;

主力:=MA(换手,4);

大户:=MA(换手,9);

中户:=MA(换手,17);

散户:=MA(换手,34);

均量:=(主力+大户+中户+散户)/4;

主力能量:(主力-均量)COLORRED,NODRAW;

大户量:(大户-均量)COLORMAGENTA,NODRAW;

中户量:(中户-均量)COLORYELLOW,NODRAW;

散户量:(散户-均量),NODRAW;

操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED;

减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLOR00CC20;

反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLOR00CCCC;

寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),'机构'),COLORRED;

操盘1:STICKLINE(大户量>=0 AND 大户量>=REF(大户量,1),3,3+大户量,1,0),COLORRED;

减仓1:STICKLINE(大户量>=0 AND 大户量< REF(大户量,1),3,3+大户量,1,0),COLOR00CC20;

反弹1:STICKLINE(大户量<0 AND 大户量>=REF(大户量,1),3,3+大户量,1,0),COLOR00CCCC;

寻底1:STICKLINE(大户量<0 AND 大户量< REF(大户量,1),3,3+大户量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(大户量>=0,2.7,3.3),'大户'),COLORMAGENTA;

操盘2:STICKLINE(中户量>=0 AND 中户量>=REF(中户量,1),1.5,1.5+中户量,1,0),COLORRED;

减仓2:STICKLINE(中户量>=0 AND 中户量< REF(中户量,1),1.5,1.5+中户量,1,0),COLOR00CC20;

反弹2:STICKLINE(中户量<0 AND 中户量>=REF(中户量,1),1.5,1.5+中户量,1,0),COLOR00CCCC;

寻底2:STICKLINE(中户量<0 AND 中户量< REF(中户量,1),1.5,1.5+中户量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(中户量>=0,1.2,1.8),'中户'),COLORYELLOW;

操盘3:STICKLINE(散户量>=0 AND 散户量>=REF(散户量,1),0,散户量,1,0),COLORRED;

减仓3:STICKLINE(散户量>=0 AND 散户量< REF(散户量,1),0,散户量,1,0),COLOR00CC20;

反弹3:STICKLINE(散户量<0 AND 散户量>=REF(散户量,1),0,散户量,1,0),COLOR00CCCC;

寻底3:STICKLINE(散户量<0 AND 散户量< REF(散户量,1),0,散户量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(散户量>=0,-0.3,0.3),'散户'),COLORGREEN;

红买盘:MA(C,3),COLORRED,NODRAW;

绿卖盘:MA(C,3),COLORGREEN,NODRAW;

黄反弹:MA(C,3),COLORYELLOW,NODRAW;

蓝寻底:MA(C,3),COLORFF9900,NODRAW;

成交量:VOL,COLORWHITE,NODRAW;

均量5:MA(成交量,5)/50000,COLORMAGENTA,LINETHICK1;

均量20:MA(成交量,20)/50000,COLOR00FFFF,LINETHICK1;

均量120:MA(成交量,120)/50000,COLOR00CC20,LINETHICK1;

B:=ZIG(3,50/5)*1;

G:=MA(B,2);

D:=CROSS(B,G)*10;

W:=CROSS(G,B)*10;

DRAWTEXT(W=10,4,'卖' ),COLORWHITE;

DRAWTEXT(D=10,4,'买'),COLORCYAN;




8.通达信成交量均线指标公式

VOL,VOLSTICK;

;流通股:FINANCE(7)/1000;市盈率:DYNAINFO(39);

换手:VOL/FINANCE(7);

收益:FINANCE(33);量比:VOL/MA(VOL,5);

MA5:MA(VOL,5),LINETHICK3;

MA10:MA(VOL,10),LINETHICK3;

MA20:MA(VOL,20),LINETHICK3;




9.量能指标源码:主动买、主卖、持币、持股      (幅图)

万手:VOL/10000,LINETHICK0,NODRAW;

AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);

预测:AA/10000;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,0,3,1),COLORYELLOW;

BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,

BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

主买:主动买/10000,COLORRED,NODRAW;

主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),

IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));

主卖:-主动卖/10000,COLORGREEN,NODRAW;

差额:(主动买+主动卖)/10000,NODRAW;

CC:=(2*C+H+L)/4;

STICKLINE(CC>REF(CC,1),0,VOL,2,DRAWNULL),COLORRED;

STICKLINE(CC<REF(CC,1),0,VOL,2,DRAWNULL),COLORCYAN;

STICKLINE(CC=REF(CC,1),0,VOL,2,DRAWNULL),COLORWHITE;

{STICKLINE(C>-1,0,VOL,3,1),COLORRED;

STICKLINE(C<O ,0,VOL,3,1),COLORFFFF00;

STICKLINE(C=O AND C<REF(C,1),0,VOL,2,1),COLORFFFF00;

STICKLINE(C=O AND C>REF(C,1),0,VOL,2,1),COLORRED;}

STICKLINE(主动买>0,0,主动买,1,0),COLOR0000FF;

STICKLINE(主动卖<0,VOL,主动买,1,0),COLOR00FF00;

持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN;

持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORMAGENTA;

五日: MA(V,5) COLORFFFFFF LINETHICK2;

三十四日: MA(V,34) COLORFF80FF LINETHICK2;

一百四十四日: MA(V,144) COLOR00FFFF LINETHICK1;




10.起爆点(副图)

 起爆点是指股票在经过一段时间横盘之后,开始展开大幅度上攻行情的临界点位。很多投资者都希望自己能够在操作股票的时候买在起涨起爆之前,所以对于股票起爆点的把握是非常关键的。这种操作方式实际上属于左侧交易,或者属于左右侧交易中间的临界点交易,这种交易相对安全可靠。

 如果投资者想在股票起涨前买入,那么需要一些辅助的判断方法才能准确选股。今天我们从互联网上寻找了一些较为易用的公式供大家选择:

获利线:EMA(WINNER(C)*100,3),COLORWHITE;

庄筹线:EMA(WINNER(C)*70,5),COLORRED,LINETHICK2;

散筹线:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,5),COLORYELLOW,LINETHICK2;

收:=WINNER(C)*100;

开:=WINNER(O)*100;

博弈K线长:MAX(ABS(收-开),ABS(收-REF(收,1))),POINTDOT,COLORWHITE;

STICKLINE(庄筹线>散筹线,庄筹线,散筹线,0,0),COLORWHITE;

STICKLINE(收>=REF(收,1),0,博弈K线长,4,0),COLORRED;

STICKLINE(收<=REF(收,1),0,博弈K线长,4,0),COLOR00FF00;

5,COLORWHITE,POINTDOT;

20,COLORYELLOW,POINTDOT;

40,COLORFFCC66,POINTDOT;

60,COLORFF00FF,POINTDOT;

CC:FILTER((CROSS(5,庄筹线) AND 散筹线<20 )*60,10 ),COLORFF00FF;

DRAWTEXT(CC ,60 ,'海底捞活鱼(抄底)' ),COLORFF00FF;

AA:= REF(庄筹线,30)>40 OR REF(庄筹线,20)>40;

AA1:=CROSS(庄筹线,散筹线);

DRAWTEXT(AA1,70,'鸡雀***'),COLOR00FF00;

BB:=CROSS(28,庄筹线) AND 散筹线>40 AND AA=1 AND LLV(L ,60 )>LLV(L ,250 );

DRAWTEXT(BB,30,'决战诱空'),COLORWHITE;

IF(BB,30,60 ),COLORFFCCCC;


11通达信主力持仓线+主力资金流指标公式 (幅图)

N:=22;

JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));

QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));

QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));

QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));

SVZL:SUM(((QJ1+QJ2)-(QJ3+QJ4))/SUM(VOL,60),0);

CZ:=SVZL-REF(SVZL,1);

STICKLINE(CZ<0,SVZL+CZ,SVZL,1,0),COLORFFFF00;

STICKLINE(CZ>0,SVZL,SVZL+CZ,1,0),COLORRED;

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;

卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;

进出量:=买量+卖量,COLOR00FFFF;STICKLINE(进出量<0,0,进出量,1,0),COLORFF6600;

STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;

STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;

STICKLINE(进出量<0,0,进出量,0.5,0),COLORCYAN;

STICKLINE(进出量>0,0,进出量,3,0),COLOR000099;

STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;

STICKLINE(进出量>0,0,进出量,1.0,0),COLOR0000FF;

STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;





12.各种量形编写成了通达信的指标公式:

VOLUME:=VOL;

量柱:V/CAPITAL*100,VOLSTICK;

倍量柱:=IF(V/REF(V,1)>1.9 AND C>REF(C,1),1,0);

高量柱:=IF(V=HHV(V,10),3,2);

低量柱:=IF(V=LLV(V,10),9,8);

缩量柱:=IF(V<REF(V,1) AND REF(V,1)<REF(V,2) AND REF(V,2)<REF(V,3),25,35);

梯量柱:=IF(V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3),11,10);

DRAWTEXT(倍量柱>0,量柱*0.99,'倍');

DRAWTEXT(高量柱>2,量柱*0.85,'高');

DRAWTEXT(梯量柱>10,量柱*0.55,'梯');

DRAWTEXT(低量柱>8,量柱*1.01,'低'),COLORYELLOW;

DRAWTEXT(缩量柱<35,量柱*1.01,'缩'),COLORYELLOW;

三日不破:=L>REF(L,3) AND REF(L,1)>REF(L,3) AND REF(L,2)>REF(L,3);

价升量缩:=IF( 三日不破 AND V<REF(V,3) AND

REF(V,1)<REF(V,3) AND REF(V,2)<REF(V,3),0,1);

先者优先:=IF(REF(价升量缩,1)=0 AND 价升量缩>0,1,0);

将军柱:STICKLINE(先者优先=1,0,V,1,0),COLORRED;    注:源码可以直接符在成交量图上使用

V=LLV(V,N),COLORRED;    (N 可根据需要填 20 日、30 日、100 日 等)



13..通达信量均线指标公式

M1:=5;M2:=10;M3:=20;M4:=120;

VOLUME:VOL,VOLSTICK;

MAVOL1:MA(VOLUME,M1),LINETHICK2;

MAVOL2:MA(VOLUME,M2),LINETHICK0;

MAVOL3:MA(VOLUME,M3),LINETHICK0;

MAVOL4:MA(VOLUME,M4),LINETHICK2,COLORYELLOW;

IF(MA(VOL,5)>=REF(MA(VOL,5),1),MA(VOL,5),DRAWNULL),COLORRED,LINETHICK2;

VAR2:=(HIGH - LOW);

VAR3:=ABS((OPEN - CLOSE));

VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));

VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);

VAR6:=((VAR3 / VAR2) * VOL);

VAR7:=((VAR4 / VAR2) * VOL);

VAR8:=((VAR5 / VAR2) * VOL);

VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));

VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);

VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));

VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));

DRAWTEXT(CROSS(MA(VOL,5),MA(VOL,10)),MA(VOL,5),'○'),LINETHICK2, COLORYELLOW;

DRAWTEXT(CROSS(MA(VOL,10),MA(VOL,20)),MA(VOL,10),'◎'),LINETHICK2, COLORYELLOW;

DRAWTEXT(CROSS(MA(VOL,20),MA(VOL,60)),MA(VOL,20),'●'),LINETHICK2, COLORYELLOW;

相对地量:STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,2.2,0),,COLORYELLOW;

地量:DRAWTEXT(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),VOL,'地量'),,COLORYELLOW;

放量:STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2.2,0),,COLORYELLOW;

高出:DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR7 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,'高出'),COLORYELLOW;

低进:DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'低进'),,COLORYELLOW;

强势参与:DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,'参与'),,COLORYELLOW;

空头释放:DRAWTEXT(((((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)) AND ((VAR6 / VOL) > 0.7)) AND VARC) AND (VAR6 > MA(VOL,5))),(VAR6 * 2),'空头释放'),,COLORYELLOW;


14.主买买盘成交量公式
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,1),COLOR0000FF;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,1),COLORFF937F;
VAR0:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交总量:VOL,POINTDOT;
主买:IF(CLOSE>OPEN,VAR0*(HIGH-LOW),IF(CLOSE<OPEN,VAR0*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  









15.模拟虚量(四条线)

参数   最小   最大    缺省

M1    2.00   500.00   5.00

M2    2.00   500.00  10.00

M3    2.00   500.00  15.00

M4    2.00   500.00  20.00

VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;

VOLUME:VOL,VOLSTICK;

MAVOL1:MA(VOLUME,M1);

MAVOL2:MA(VOLUME,M2);

MAVOL3:MA(VOLUME,M3);

MAVOL4:MA(VOLUME,M4);



16 模拟虚量(四条线)加了主力买入

参数   最小   最大    缺省

M1    2.00   500.00   5.00

M2    2.00   500.00  10.00

M3    2.00   500.00  15.00

M4    2.00   500.00  20.00

VOLUME:VOL,VOLSTICK;

MAVOL1:MA(VOLUME,M1);

MAVOL2:MA(VOLUME,M2);

MAVOL3:MA(VOLUME,M3);

MAVOL4:MA(VOLUME,M4);

VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;

STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,1),COLOR0000FF;

STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,1),COLORFF937F;

VAR0:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

成交总量:VOL,POINTDOT;

主买:IF(CLOSE>OPEN,VAR0*(HIGH-LOW),IF(CLOSE<OPEN,VAR0*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));

买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));



17.主力模拟虚量(成交总量与主买量)

参数   最小   最大    缺省

M1    2.00   500.00   5.00

M2    2.00   500.00  10.00

M3    2.00   500.00  15.00

M4    2.00   500.00  20.00

VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;

VOLUME:VOL,VOLSTICK;

STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,1),COLOR0000FF;

STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,1),COLORFF937F;

VAR0:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

成交总量:VOL,POINTDOT;

主买:IF(CLOSE>OPEN,VAR0*(HIGH-LOW),IF(CLOSE<OPEN,VAR0*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));

买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));


版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

文章链接:

股票开户

免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

官方千人交流Q群8:1500113880

官方千人交流微信群1:rafczx




股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

 Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

为股民提供指标公式,选股公式,股票公式,股票软件,股票入门基础知识,炒股公式,炒股软件,手机炒股,炒股入门,是投资理财和股票行情,今日股市行情,股吧,指标公式网

内容来源于网络,若无意中侵犯您的版权,请联系删除!


浙ICP备17017803号-1
微信公众号 回顶部
关闭
“炒股公式”width="90"
关闭
“抄底公式”
关闭
关闭
关闭
关闭